Support » Plugin: WordPress Shortcodes Plugin — Shortcodes Ultimate » Youtube no longer works

  • Resolved inselhopper

    (@inselhopper)


    In all my pages, the Youttube embedding no longer works. It keeps showing “This video is not available” even though the video is there. The normal embed code from Youttube works, but shortcode does not. Has Shortcode now been blocked by Youtube?

    Example see link

    • This topic was modified 1 year, 4 months ago by inselhopper.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 26 total)
  • I’m having the same problem. I have tried turning off all the plugins and changing the theme but the problem persists.

    Please, since the day before yesterday after the release of WordPress, the problems started for many plugins and for youtube links. You have to run for cover, the problem is global.
    The director
    by Umbriajournal and umbriajournaltv

    Thread Starter inselhopper

    (@inselhopper)

    Found the problem. su_youtube_advanced does not work. I changed su_youtube_advanced to su_youtube in the database, then everything worked again.

    The youtube_advanced shortcodes creates an empty “playlist” parameter in the Youtube URL which is no longer accepted by Youtube.

    Temporary fix: add loop=”1″ in your shortcode parameter.

    The plugin needs to be fixed: avoid adding empty “&playlist=” parameter to the Youtube URL.

    Found the problem. su_youtube_advanced does not work. I changed su_youtube_advanced to su_youtube in the database, then everything worked again.

    Thank you very much!

    Looking forward to the update.

    And what to do with a lot of similar inserts, in one or two posts can be done (su_youtube), but what to do from 10, 20, 100 articles?

    Maybe someone knows how to make a variable to fix all such problems with this plugin to eliminate?

    I had a customer with this problem too. The loop=1 workaround worked, but the site has hundreds of embedded videos so it wasn’t practical. I thought about adding loop=1 in a database search/replace but that seemed dangerous and time consuming (if it didn’t work right the first time).

    I confirmed the issue just popped up, while this site was using version 5.9.0 of the plugin, and I tried a few versions between that and 5.10.1 with the same result. Based on this I think the change might have been at youtube, deciding “playlist=” is an error, whereas before it was ignored.

    I eventually decided to kludge this in the plugin code.
    In the file includes/shortcodes/youtube-advanced.php around line 212 I changed this:
    if ( '1' === $url_params['loop'] && '' === $url_params['playlist'] ) {
    to this:
    if ( '' === $url_params['playlist'] ) {

    Now it’s worked around, without the loop=1 parameter being needed. I’m assuming this will all get worked out somewhere before the next update of this plugin.

    • This reply was modified 1 year, 4 months ago by Mark Costlow. Reason: spelling

    Thank you @swcp Mark! This works.

    Thank you @swcp Mark!

    @swcp, you are a big one! Thank you very much! Everything works!

    @swcp Same problem, but there is no file on my host to add this code. The page I need help with: https://www.selviozelegitim.com/

    Did change the Code in SublimeText and replaced

    if ( '1' === $url_params['loop'] && '' === $url_params['playlist'] ) {

    with
    if ( '' === $url_params['playlist'] ) {

    but the issue remains.
    Did I do anything wrong?

    @mustafaaksoy the file is in the shortcodes-ultimate plugin directory. From the top level of your WordPress site, it would be in wp-content/plugins/shortcodes-ultimate/includes/shortcodes/youtube-advanced.php

    @highzera That should do it. In some environments it takes a couple of minutes before the server will see the change. If it’s still not working after 5 minutes or so then I’m not sure what the issue may be.

    If you “View Source” on the web page with the video, search for the youtube.com link, does the URL have “playlist=” in it?

    • This reply was modified 1 year, 4 months ago by Mark Costlow. Reason: formatting

    @swcp
    Thank you for your help.
    It is still not working.
    I changed the Code in SublimeText and overwrote the file via FileZilla.

    I deactivated the auto update in WordPress as i thought it might would overwrite my changed file but it still doesnt work.

    This is one page where we have Videos linked via su_youtube_advanced
    https://technikermathe.de/courses/ma1-grundlagen-der-mathematik

    I appreciate your help!

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘Youtube no longer works’ is closed to new replies.