Support » Plugins » Youtube Lyte plugin breaking quicktags and javascripts

  • Resolved S.K


    I encountered a weird behaviour on one of my sites using this plugin. Suddenly quicktag buttons on html edit form disappered and Google api javascripts stopped functioning. I disabled Youtube Lyte plugin and everything became all right. I tried a fresh download from the plugin repository to the same result.

    Please get it fixed.



Viewing 15 replies - 1 through 15 (of 22 total)
  • Hi SK. Quick question before I dive in: the google api javascripts that stopped functioning, was that in the wp-admin part (as were the quicktags), or in the blog front-end as well?

    And did you happen to check with firebug (or a similar javascript tool) to check what errors were thrown, or can you re-enable for a second and check (because I can’t reproduce)?

    Thanks, Futtta for your response.

    Yes, the problem is both on the front end and the admin part. I tried re-enabling and checking with firebug. It shows a big chunk of errors which turns me dizzy.

    I’ll try it with another site of mine to find out if it conflicts with another plugin.


    ideally you would be able to reproduce this an a non-production site (or one which can be broken for a couple of hours) which would allow me to go bug-hunting there myself? 🙂

    but feel free to copy/paste that big chunk of errors here or into a mail to futtta-at-gmail-dot-com

    just a silly idea: do you have DoNotTrack (the “bonus feature”) disabling 3rd party tracking? if so, can you try without that option to see if that solves the problem? I would still be very interested in the errors you got though (I’m working a new plugin that’ll do nothing but DoNotTrack)

    Futtta, you are dead on!

    I disabled DoNoTrack and everything is hunky dory!
    But I need the do-not-track thingy too. Any non-conflicting version of it?

    Thanks and regards


    ok, now we’re getting somewhere. to solve this, i’m afraid i’m really going to need the javascript-errors generated by donottrack-min.js, either by being able to see them for myself in firebug on a site of yours, or by having a copy/paste dump from your firebug or javasript error console. what do you think?

    Please see the blank space under the heading “Search site” on the side bar of and the content area of (under “loading”).

    Hope this helps.


    Weird, can’t see any trace of donottrack-related errors in the firebug-output, the only output I see is related to the google custom search implementation:

    “NetworkError: 404 Not Found –
    default+en.i.js is not a constructor
    Line 301

    Which seems to imply that the js-loader did not succesfully load the search javascript-file because the wrong hash (?) was used. The question is; where does that hash (b30fd838d9675ca5b151bcc19ff5c9c8) come from? and in what way could donottrack interfere?

    Can you disable donottrack, I’d like to see if that URL (the hash inside it) is different. maybe that way I’ll start to understand what is going on here …

    Well, I digged some more, the hash (and full URL) are defined by Google in a response right after initiating the search.

    This is what’s happening:
    * jsapi (javasript loader) is loaded successfully
    * search starts initiating (the google.load line)
    * is called successfully
    * that file contains a URL (including hash) for a javascript file which (a.o.) defines
    * that javascript file cannot be loaded (gives a 404)
    * because isn’t know, a javascript error is thrown

    questions remaining:
    * how can DoNotTrack cause this (I’m really stumped up until now to be honest)?
    * can you disable DoNotTrack so I can see what is different in that case?

    //can you disable DoNotTrack so I can see what is different in that case?//

    Yes. I have done it. Please have a look.


    OK, I think I found the problem (a stupid mistake on my part which results in a document.write’s not being executed).

    can you replace your version of donottrack-min.js with the one on this should solve the problem.

    if it does, i’ll push out wp-youtube-lyte (with some other fixed) later today, if not i’ll just have to keep on poking around 😉

    I was kind of impatient and pushed wp youtube lyte v0.9.3 out, i’m pretty confident it solves the issues you encountered 🙂

    Thanks. It (donottrack) almost fixes everything except the Google custom search code which still plays truant. I haven’t looked at the analytics thing yet.


    arghhhhhhh … really thought I had cracked it. do you use a plugin for google custom search? which one?

    and is (was) there an analytics problem as well? what’s going wrong there?

    I inserted the Google CSE code myself and added a search form widget on the sidebar. I have just now added the Google analytics. So I’ll have wait for a day to check if it has started tracking.

    You can see the custom search still “loading” on (sidebar) with DoNotTrack on.



Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Youtube Lyte plugin breaking quicktags and javascripts’ is closed to new replies.