Support » Theme: OceanWP » YouTube embed video issues

Viewing 15 replies - 1 through 15 (of 19 total)
  • I am having the same issue and it’s really frustrating. The fix from the thread you posted hides the space on some of my videos but makes others videos disappear completely.

    The problem is fixed by changing themes so it does seem like an OceanWP bug.

    Hoping for a helpuful response from support.

    Thread Starter Manu

    (@manuxx34)

    Hi Lamayas, is really frustrating cause it has been reported since 2018, there are like 10 posts in this forum and in Github related to the bug in OceanWP.

    And yes, for us the one shared also caused the video to dissapear, other fixes shared here only solve it for chrome and make the video dissapear in other browsers.

    Could someone from the support team please give us the correct code or give us a solution?

    Hello,

    We are sincerely sorry for all the problems and thankful for your patience and for support in spite of these problems more than you can imagine. I am happy to inform you that very soon we’ll be releasing a new theme update covering Gutenberg updated compatibility and this problem will be addressed as well, among additional changes.

    For the time being, try using the following CSS and let me know if this helps temporarily resolve the problem:

    .wp-embed-responsive .wp-embed-aspect-16-9 .wp-block-embed__wrapper:before {
        padding-top: 50px;
    }

    Thank you very much

    Hi Abhishek, I’m happy to hear that!

    The css did not worked unfortunately, it makes some of the videos look really short, here’s a screenshot:
    https://www.awesomescreenshot.com/image/6672201?key=0268a08bff5d5549d38a8fbb566e9549

    Looking forward to the update, thanks for your help.

    Thread Starter Manu

    (@manuxx34)

    Thanks for reply, sadly we got the same effect as Lamayas with the video showing super reduced and cut off.

    Regards

    Hello,

    Visited the shared URL but not facing the mentioned issue: https://ibb.co/c1WkYGd

    can you please share the exact page URL where you facing this issue?

    Thread Starter Manu

    (@manuxx34)

    Hi Abshishek, in the posted URL your code seems to do the job although I don’t think setting a custom padding is the best solution since every user will use different spacer settings.

    However we have another site and the effect of applying your code is the same as lamayas posted. Please take a look at how it displays without any extra code: https://abogado.la/perdon-migratorio/

    You can see the huge space above the video (right after the first H2 heading)

    Please try on a clean OceanWP installation and you will notice the same bug when embedding a YouTube video,

    Regards

    • This reply was modified 8 months, 2 weeks ago by Manu.
    • This reply was modified 8 months, 2 weeks ago by Manu.

    The space you are facing above the heading is coming from some plugin and a spacer added to create a space.

    https://ibb.co/nqG270s

    Thread Starter Manu

    (@manuxx34)

    Are you sure Abhishek? we don’t use any plugin other than elementor that could affect the view and that page is default gutenmber. This happens in 3 OceanWP installations.

    Also changing those values makes no effect in Developer tools.

    https://ibb.co/jfXT17z

    There is no “block spacer” used between the video and the text above and below.

    Please check screenshot and correct me if I’m wrong but developer tools is pointing exactly to the default Gutemberg block to embed YouTube videos.

    Hi Abhishek, I just updated to version 2.0.4 and the issue is not fixed.

    Can you offer a temporal fix? Thanks for your help!

    Hello,

    Kindly replace the previous code with this one.

    .wp-embed-responsive .wp-embed-aspect-16-9 .wp-block-embed__wrapper:before {
        padding-top: 56.25%;
    }

    Thank you Abhishek.

    With this css the videos reappeared.

    *Sorry about my English.

    Thread Starter Manu

    (@manuxx34)

    Sorry but that same code for me creates a massive space, please check: https://abogado.la/perdon-migratorio/
    https://www.lluislaw.com/es/perdon-de-inmigracion-i-601/

    Same effect in two different sites.

    Looks good in Firefox however… no space there… I’ve cleaned cache and so on but still can’t get rid of that huge white space above in chrome.

    EDIT:

    I saw your post here: https://wordpress.org/support/topic/gap-between-blog-content-oceanwp/

    The code that worked for us is:

    .wp-embed-responsive .wp-has-aspect-ratio iframe {
        padding-top: 0px;
    }

    Thanks

    • This reply was modified 8 months, 1 week ago by Manu.
    • This reply was modified 8 months, 1 week ago by Manu.
    • This reply was modified 8 months, 1 week ago by Manu.

    Actually, that issue has been fixed in our latest update 2.0.4, Kindly update the theme to the latest version, remove the previously added codes for that and check.

    Hi Abhishek, the issue seems to be fixed with the update. But I had to delete and embed my videos again.

    If I use the short version of the URL I can see the video in the editor but not in the live post. Not sure if that’s related.

    Thanks again for your help.

Viewing 15 replies - 1 through 15 (of 19 total)
  • You must be logged in to reply to this topic.