Support » How-To and Troubleshooting » YouTube code disappears!

YouTube code disappears!

  • So here’s the story:
    I have a YouTube channel and the videos belong to me.
    I take the embed code (iframe) and paste it into a WordPress post.
    If I click Publish, it works, no problems.
    But if I schedule it to be published at a later time – including one minute from now, as I just tested – the embed code disappears.
    All other content of the post remains, but the whole iframe is gone.
    I schedule a new video to be posted every Monday and have been doing so for over a year with no problems. The first time this happened was January 7. I can’t be sure, but is that around the time the new version of WordPress came out?
    Any ideas why this is happening?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The first question is have you installed any new plugins or activated a new theme around Jan 7th? Or did you upgrade WordPress around that time?

    No new plugins. I update WordPress every time it tells me to, so whenever the new version came out, that’s when I updated it.

    I’m having the same issue on a site that I manage for a client. I’m creating/scheduling posts in advance, with Youtube videos that are scheduled to go live at the same time. For some reason, the entire embed code disappears when it publishes at midnight, so I’m having to set my alarm clock to wake up and manually put the embed code back in. (aaarrrgh!)

    I’m using the latest version of WP and all the plugins are up to date.

    Any ideas or suggestions for how to fix this??? Does anyone know of a plugin that I can use as a workaround solution?

    Moderator kmessinger


    Forum Moderator

    This is a known issue and will fixed in 3.6.

    [edit] See, http://wordpress.org/support/topic/publish-scheduled-posts-in-35?replies=7&view=all

    Good to know. Thank you!

    In the meantime … is there something I can mess with in the php to make my posts publish properly?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘YouTube code disappears!’ is closed to new replies.