Support » Fixing WordPress » YouTube Blurry Thumbnails

  • Hello,

    Every time I try to embed a YouTube video link, it produces a blurry thumbnail. This is with the OEmbed feature. Has anyone else experienced this problem? If so, what’s the remedy for clear thumbnails. When I use the full embed code method, the thumbnails are clear. So this has to be some weird issue with the OEmbed process.

Viewing 5 replies - 1 through 5 (of 5 total)
  • This is actually not a WordPress issue. It is a problem with the images uploaded to YouTube by the video author. I had the same problem with videos I was uploading for a client about a month ago and it took me about an hour to realize that the problem as actually being cause by the images provided by the client to use as thumbnails over on YouTube.

    Hope this helps.

    If that’s true, then why do I get a clear image when I use the YouTube video embed code?

    I am not certain. My client was using oembed with Classic Editor. Results may vary if you are using a theme’s page builder and/or Gutenberg Editor

    Are you setting the dimensions as this article shows how to? https://codex.wordpress.org/Embed_Shortcode

    [embed width="123" height="456"]...[/embed]

    I’d suggest setting the dimensions to be the same as the embed iframe that youtube provides and see what result you get.

    Wow, just figured out that the problem was a plugin I had activated to try to speed up video load times. It’s call Lazy Load for Videos. I deactivated it for now and the problem cleared up instantly. Guess I will have to contact them to see why it produced those bad results. Thanks for replying.

    Never would have guessed that. Glad you figured it out. Happy blogging.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.