WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Youtube Autoplay

[Resolved] Youtube Autoplay

Viewing 11 replies - 1 through 11 (of 11 total)
  • Go to Settings > Plugins > WP Video Lightbox, and set this to “true”
    $vid_lightbox_autoplay = 'true';

    I personally did not find a setting section for WP Video Lightbox. Also, adding &autoplay=1 to the link doesn’t work either. This is what I did instead:

    1. Go to plugins.

    2. Under “WP-Video-Lightbox”, click “Edit.” This opens the relevant plugin files.

    3. You will automatically open the 1st file (wp-video-lightbox/wp-video-lightbox.php). Scroll to the middle of the file and you should see:

    $vid_lightbox_autoplay = ‘false’;

    4. Change ‘false’ to ‘true’.

    5. Celebrate.

    -RON

    Thanks tzzel, that worked a treat! 🙂

    My code doesn’t have that. Where do I insert the “$vid_lightbox_autoplay = ‘false’;?”

    Plugin Author mra13

    @mra13

    Open the “wp-video-lightbox/js/video-lightbox.js” file and search the following:

    autoplay: false

    Once you find it, change it to the following:

    autoplay: true

    Hey there – I found a solution to this for Lightbox Plus Colorbox. Simply add:

    “?rel=0&autoplay=1”

    to the end of your Youtube embed link, and the video should play automatically. No change of settings required.

    Hope that helps!

    @tmcguinness I tried your suggestion and that doesn’t work for me.

    changing false to true does work, but can this not be accomplished with the shortcode so a plugin update doesn’t reset this value?

    I was able to get a Vimeo video to successfully auto play with shortcode by adding “?autoplay=1” to the end of the video ID.

    Example:

    [video_lightbox_vimeo5 video_id= 12345678?autoplay=1 width=xx height=xx anchor=”xx”]

    Where 12345678 is the Vimeo video ID. Hope this helps.

    Thanks for the suggestion Mike.

    I just tried and it didn’t work for YouTube.

    [video_lightbox_youtube video_id=tMfu5aSXU8U?autoplay=1 width=640 height=360 anchor=”Watch Our Video”]

    Will you try my code on your site just to see if it works for you?

    Any update on this on a PER LINK basis please?

    Working for me:

    VIMEO: add ‘&autoplay=1’ to link

    YOUTUBE: add ‘?rel=0&autoplay=1’ to link

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] Youtube Autoplay’ is closed to new replies.