Easy FancyBox
[resolved] YouTube and Vimeo links not preventing new window (5 posts)

  1. leggo-my-eggo
    Posted 2 years ago #

    Take a look here: http://ilanadavidson.hatheadstudios.net/2013/03/fancybox-test-link/ and click the "Vimeo Test Link".

    For some reason, although a Fancybox iframe popup is opened, and works, the link also opens a new Vimeo window with the link.

    Same thing happens with YouTube. This was working until recently. I'm using 1.5.0dev11

    Any clue what's going on? Chrome is also throwing an error:

    Unsafe JavaScript attempt to access frame with URL http://ilanadavidson.hatheadstudios.net/2013/03/fancybox-test-link/ from frame with URL http://player.vimeo.com/video/62089497?. Domains, protocols and ports must match.

    Which it attributes to swfobject.js, which is only loading inside the vimeo iframe.


  2. leggo-my-eggo
    Posted 2 years ago #

    Never mind. I'm an idiot.

  3. RavanH
    Plugin Author

    Posted 2 years ago #

    How did you resolve the issue? Others might benefit from your experience :)

  4. leggo-my-eggo
    Posted 2 years ago #

    @RavanH, I didn't post it because I didn't think it would be relevant to anyone else (and because it's a little embarrassing). I had, a few days ago, added a script to open all offsite links in a new window and forgotten about it.

    So, I made that script aware of the fancybox links and now all is well.


  5. leggo-my-eggo
    Posted 2 years ago #

    I should actually add that the error is still, in fact, thrown. It shown up in the Chrome Developer's Console. It just doesn't seem to affect anything.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic