Support » Plugin: Yoast SEO » You’re linking to another page with….. – Can’t locate

  • Resolved rob33

    (@rob33)


    You’re linking to another page with the words you want this page to rank for.

    My apologies for digging up a repetitive issue posted online, but with WC updated, I am still seeing this on this page yet can’t for life of me locate.

    Is there a tool to check such errors location?

    Thanks all,

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Support Jerlyn

    (@jerparx)

    Hi @rob33 ,

    We are sorry to hear about the difficulties you are having. That warning is normally a result of the focus keyphrase being part of the anchor text for a link. Can you please check all the links on that post/page if any of those contain the focus keyphrase? If it does, you need to change the texts to something else. Please refer to this kb article to learn more: https://yoast.com/how-to-improve-your-link-text/

    It’s important to note though that the plugin will flag any occurrence of the focus keyphrase in any order of the words.

    While there is no tool yet to check the errors location, a request to improve this feature is already created and is currently under review by our product team.

    What’s next?
    Our product team will assess feature requests in relation to other open bug reports and new features. Based on their assessment, the feature request will be given a priority. Our developers work on the highest priority first. Unfortunately, this means we cannot give you an estimate if or when they’ll start working on your request.

    rob33

    (@rob33)

    Thanks Jerlyn,

    The only place I have this is in an image name which you can see labelled –

    https://menspleasures.com/wp-content/uploads/2020/11/Fleshlight-Turbo-Thrust-blue-ice-inner-chamber-scaled.jpg” alt=”Fleshlight Turbo Thrust blue ice inner chamber” width=”2560″ height=”590″ />

    Would this account for the error? Could you kindly take a look at the page linked-
    https://menspleasures.com/product/fleshlight-turbo-thrust/

    I have checked all posts/pages/products content and this is the only place I use this kw and it is not linked on this page from what I can tell.

    Thanks.

    • This reply was modified 2 months ago by rob33.
    • This reply was modified 2 months ago by rob33.
    Plugin Support Pcosta88

    (@pcosta88)

    Hi,

    We would like some more information.

    1. Are all your non-Yoast plugins and themes also updated?

    2. We had another recent release. Can you confirm you are using the most recent Yoast SEO, v15.3? If you update, does the issue resolve?

    3. To clarify, the keyword for the page is: Fleshlight Turbo Thrust blue ice inner chamber?

    4. We suggest clearing your browser’s cache using this guide: https://kb.yoast.com/kb/how-to-clear-my-browsers-cache/ and removing your cookies using this guide: https://us.norton.com/internetsecurity-privacy-how-to-clear-cookies.html.

    rob33

    (@rob33)

    Hi there,

    1. Yes all updated except GeneratePress plugin which requires cost which have to postpone for now.

    2. Updated to 15.3

    3. kw is – Fleshlight Turbo Thrust – I have changed image name to remove this.

    4. Cleared everything “from all time”.

    No joy.

    Plugin Support Suwash Kunwar

    (@suascat_wp)

    Hi @rob33

    We understand the keyword is Fleshlight Turbo Thrust and you’ve manually confirmed a single occurrence there’s no link that includes the focus keyword but the analysis is still pointing that keyword is linking to another page. We understand that sometimes it’s tempting to attempt to get all green lights on the SEO analysis. However, these are general guidelines, not strict rules that will hurt your ranking. If you feel your page is properly formatted and has a good user experience, then these warnings can be safely ignored and you should not sacrifice user experience to get the green bullet.

    You can read more about this on this article on our website: https://yoast.com/want-green-bullet-wp-seo/

    rob33

    (@rob33)

    Thanks Suwash,

    Sound words. Understand there will be little niggles here and there.
    Reassuring – appreciated.
    Been thru source page thoroughly and not seeing it.
    Maybe it’s a woocommerce Product Tag conflict; will move on.
    It’s happening with each new Product I publish now so something amiss.
    Also getting “Keyphrase in title: Does not contain the exact match” in other Product pages but this is not the case.

    Cheers.

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    It’s very odd that you are seeing the “you’re linking to another page with the same focus keyphrase” with every new product you are publishing on your site as you can confirm that you haven’t used the relevant focus keyphrases before anywhere on your site.

    If you want us to still investigate the issue further for you, we recommend you to run a final conflict check t see whether this shed some light on the issue for you. You can find the conflict check guide here https://yoast.com/help/how-to-check-for-plugin-conflicts/.

    In regards to the “keyphrase in the title: does not contain the exact match” warning, are you using the same focus keyphrase in the SEO title? If not, you’ll need to add the focus keyphrase exactly on the title.

    However, if you have already used the focus keyphrase in the SEO title exactly in the way you have defined in the focus keyphrase field and the warning persists, can you please try wrapping the relevant focus keyphrase using the double quotes "" to see whether this resolves the issue for you?

    We look forward to hearing from you.

    rob33

    (@rob33)

    Hi,

    So far:

    1. Tried the “” in SEO Title – still:
    Keyphrase in title: Does not contain the exact match.
    This is one page where it occurs:
    menspleasures.com/product/pink-lady-fleshlight/

    2. Tried site health and deleted all nonactive plugins and themes.

    3. Previously disabled all plugins except wc products and seo yoast.

    4. Disabled “related products” wc feature so will stop the same product page appearing at bottom of page even though this should not occur.

    One thing:

    All new product pages published last few days show just the one error:

    Link keyphrase: You’re linking to another page with the words you want this page to rank for.

    Most, not all product pages published more than a month ago include both:

    Link keyphrase: You’re linking to another page with the words you want this page to rank for.

    and Keyphrase in title: Does not contain the exact match.

    rob33

    (@rob33)

    Edit: Most not “all” regarding products posted last few days.
    Just published new product and getting “Keyphrase in title: Does not contain the exact match”

    Source page title is: <title>Fleshlight Maitland Ward – Their Craziest Texture Yet? – Men's Pleasures</title>

    Fleshlight Maitland Ward – is the KW.
    menspleasures.com/product/fleshlight-maitland-ward/

    It is exact, so, will try delving deeper in time.

    • This reply was modified 2 months ago by rob33.
    Plugin Support Priscilla Chapman

    (@priscillamc)

    Hi @rob33,

    We’d like to make sure that the false positives that you’re seeing aren’t due to an error or a conflict.

    For a page where this is happening, please try the steps below:

    1. Check for JavaScript errors in the console.

    2. Check for conflicts.

    3. Are you using any third-party page builder plugins? Do these errors appear if you use the default block editor or the Classic Editor?

    rob33

    (@rob33)

    Don’t you mean false negatives?
    Checking now, thanks.

    Plugin Support Priscilla Chapman

    (@priscillamc)

    Hi @rob33,

    Yes, we’ll leave this topic open for the next week just in case you have any updates.

    Plugin Support Michael Tina

    (@mikes41720)

    Setting this to resolved to keep the forum overview.

    Hi – it’s not resolved but out of angles this end.

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.