Support » Plugin: Ultimate Member – User Profile, User Registration, Login & Membership Plugin » Your username contains invalid characters

  • TAC28

    (@tac28)


    Hi,

    I am trying to add a member but keep getting the error message “Your username contains invalid characters”.

    However, the field only has standard characters in it.

    What could be causing this?

    Thanks 🙂

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Support Ultimate Member Support

    (@ultimatemembersupport)

    Hi @tac28,

    Can you please provide sample usernames that trigger the error?

    Thanks.

    borisv

    (@borisv)

    Try deactivating the UM plugin and try to add a user on the admin panel of WordPress. This may not even be a UM issue at all…

    TAC28

    (@tac28)

    Hi @ultimatemembersupport and thank you.

    The username is Jaguar Energy Ltd

    I have a screen shot of the error if that helps?

    • This reply was modified 4 years ago by TAC28.
    • This reply was modified 4 years ago by TAC28.
    TAC28

    (@tac28)

    Hi @borisv

    I was able to add a WP user called Jaguar Energy Ltd no problem.

    I need to add them via the registration form anyway as there are other bit of information I need on the member profiles.

    borisv

    (@borisv)

    I am not sure what your problem is. That you can’t register the user name ‘Jaguar Energy Ltd’ with UM, or that you can’t add details on the profile page.

    BTW, if you can’t even register that name, that’s the least of your problems. That would be, to put it mildly, a rare issue at best.

    You should provide a link to your registration form.

    • This reply was modified 4 years ago by borisv.
    borisv

    (@borisv)

    BTW, can you provide a link to your registration form

    TAC28

    (@tac28)

    My problem is that when someone tries to register here http://granthambusinessclub.co.uk/join-us/ using the business name Jaguar Energy Ltd they get the error “Your username contains invalid characters”.

    Here is the screenshot http://vrdesigns.co.uk/wp-content/uploads/2016/10/Screen-Shot-2016-10-17-at-12.01.58.png

    lennoxfretz

    (@lennoxfretz)

    After a quick look at your source code (using chrome), I can see that your “Business Name” field is actually a “Username Field”, which can’t have spaces in them (this is because username fields use unique username as verification and unique usernames can’t have spaces in them)

    To change this, you should delete your current “Business Name” field and replace it with a classic Text Box Field. To make sure spaces are taken into account, use the “Verification” setting.

    Plugin Support Ultimate Member Support

    (@ultimatemembersupport)

    Hi @tac28,

    As mentioned by lennoxfretz, the error is caused by the spaces. WP core doesn’t accept spaces in username. This may require customization as UM is using wp_create_user.

    Thanks.

    borisv

    (@borisv)

    Yep. That would be the only reason.

    However, some company web sites prefer to provide their users with profiles showing urls with their company names, not their usernames (e.g. nicky) or first/last names.

    You can simply add text help next to the label that says “this would be the url to your page” and a placeholders showing them an example of how it should be (e.g. jaguar-energy-ltd).

    TAC28

    (@tac28)

    Wow thank you so much everyone for your help.

    @lennoxfretz that would never have occurred to me to think of that.

    I’ve tested the form and it worked 😀

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Your username contains invalid characters’ is closed to new replies.