WordPress.org

Forums

NextGEN Gallery
Your theme page template didn't make a call for wp_footer() and lightbox problem (4 posts)

  1. Guy Scharf
    Member
    Posted 1 year ago #

    Just updated to NEXTgen 2.0.11 and started seeing PHP error log entries as described in the topic title. Also, lightbox doesn't work; images are opened in the same window (IE) or in a new tab (FF which forces a new tab instead of using the same one).

    This error apparently started happening immediately after upgrading toe 2.0.11.

    I am using a child theme of Twenty Eleven.

    http://wordpress.org/plugins/nextgen-gallery/

  2. Anthony Somerset
    Member
    Posted 1 year ago #

    i'm having this same error with a different theme, but things seem to be working ok

    things seem to be working ok for me right now however my error log is filling - i get the message on wp_cron requests as well....

    i looked at a couple of the themes .php files (castiel theme) that were generating the error, they were loading wp-load.php to get the variables to dynamically generate css or js output but obviously those scripts did not call wp_footer for obvious reasons

    it looks like the error could be related to the use of w3-total-cache - as the error text is only found in nextgen-gallery/non_pope/class.photocrati_resource_manager.php on lines 121-129

    // If W3TC is installed and activated, we can't output the
                            // scripts and manipulate the buffer, so we can only provide a warning
                            if (defined('W3TC')) {
                                    define('DONOTCACHEPAGE', TRUE);
                                    if (!did_action('wp_footer')) {
                                            error_log("We're sorry, but your theme's page template didn't make a call to wp_footer(), which is required by NextGEN Gallery. Please add this call to your page templates.");
                                    }
                                    else {
                                            error_log("We're sorry, but your theme's page template didn't make a call to wp_print_footer_scripts(), which is required by NextGEN Gallery. Please add this call to your page templates.");
                                    }
                            }

    this check is obviously over-zealously and wrongly checking some files

  3. Guy Scharf
    Member
    Posted 1 year ago #

    Good detective work there. The error message goes away when I deactivate W3TC. I'll have to do some testing to see what the impact of that is (we weren't using the page caching feature anyway).

    However, the lightbox is still not working. Maybe that's an incompatibility with some other plugin?

  4. rtb1982
    Member
    Posted 1 year ago #

    I can not get my light box to function unless I disable my theme and use twenty-thirteen.

    It appears to be an issue with the theme but a bug-fix was sent in which seems futile as the number of issues they have is so huge I doubt they will ever look at it....

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • NextGEN Gallery
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.