Support » Plugin: WooCommerce » Your store does not appear to be using a secure connection….

  • Resolved mrspumpkin

    (@mrspumpkin)


    Just updated to v3.4.1 and have this message ribbon on my dashboard:

    Your store does not appear to be using a secure connection. We highly recommend serving your entire website over an HTTPS connection to help keep customer data secure.

    But I have always had HTTPS, since before I installed WooCommerce, and ran the check on SSL Server Check (got an A) so not sure why this is happening.

    Does anyone else have the same problem since the update?

    The page I need help with: [log in to see the link]

Viewing 7 replies - 16 through 22 (of 22 total)
  • Plugin Support ryanr14

    (@ryanr14)

    Ah, sorry to hear @mrspumpkin.

    Just to confirm a few things here to hopefully find a solution.

    • Your WordPress Address (URL) & Site Address (URL) use HTTPS, not HTTP.
    • Stripe is using version 4.1.6, if you were using Stripe.
    • PHP is at version 7.0 at a minimum.

    And if you think of or notice anything else that could be causing the issues there let us know. 🙂

    Your WordPress Address (URL) & Site Address (URL) use HTTPS, not HTTP. – It is – I was https before I installed WooCommerce and have changed it in the WP site settings.
    Stripe is using version 4.1.6, if you were using Stripe. N/a
    PHP is at version 7.0 at a minimum. – Am at 7.1.17

    Plugin Support Thomas Shellberg

    (@shellbeezy)

    Automattic Happiness Engineer

    @mrspumpkin some WooCommerce plugins(like Stripe) have their own “Secured Checkout” check which might need to be updated as was the case with Stripe. Hard to know now but a test in the future would be to disable plugins other than WooCommerce and see if the message persists.

    The message was direct from WooCommerce itself, rather than a WordPress thing. I’ve x-d out the banner now so don’t have a screenshot unfortunately.

    Plugin Support Thomas Shellberg

    (@shellbeezy)

    Automattic Happiness Engineer

    @mrspumpkin – Right, sorry if that was unclear; the message comes from either WooCommerce or a WooCommerce extension(Stripe was an example mentioned earlier).

    As far as WooCommerce itself is concerned, it checks to see if either the Shop page is loaded via HTTPS or the native is_ssl() function returns true.

    For future people looking at this thread, the spurious message could be caused by hosts utilizing load balancing:

    https://developer.wordpress.org/reference/functions/is_ssl/

    I’m receiving this message too and I’m all on SSL, correct url’s. It really should add some details to know what’s going on and what should be fixed or at least to know where does the error come from (WordPress/site URLs or the is_ssl() thing).

    I had this exact same problem, and it was super frustrating. I started building a site two years ago and abandoned it. Recently picked it back up, had to update WordPress, WooCommerce, my theme, plugins, etc, and then all of the problems started. I was getting the same error message in WooCommerce, but my hosting provider and every SSL check website was showing me as secure. Here are the things I tried that did not resolve the issue:

    1. Changed both URLS to include HTTPS
    2. Switched PHP from 7.0 to 7.2 because I was getting a potential warning message regarding that
    3. Re-uploaded a lot of my images because I was occasionally getting an SSL error message for random ones on SSL check sites like my logo and my shopping cart icon.
    4. Siteground did the following trying to fix it: It was a mixed content of the website – I have added a directive to your .htaccess and this has fixed the mix content error
    4. Other minor tweaks here and there, nothing worked

    What finally worked was simply deactivating the WooCommerce plugin, reactivating, and clearing cache, the error message went away immediately after that. I felt so dumb to have spent 8+ hours trying to figure this out and never thought to deactivate the WooCommerce plugin although I did try activating and deleting other plugins that I thought may have been giving me issues.

Viewing 7 replies - 16 through 22 (of 22 total)
  • The topic ‘Your store does not appear to be using a secure connection….’ is closed to new replies.