Support » Plugin: Yoast SEO » Your Sitemap appears to be an HTML page.

Viewing 3 replies - 1 through 3 (of 3 total)
  • I am also getting this error.

    Where there are more that 1000 of a post type WordPress SEO splits them into separate sitemaps – you should see this if you visit your sitemap_index.xml

    Where I have more that 1000 of a custom post type (may affect standard posts/pages too, I don’t know) the first XML file “my-custom-postype-sitemap1.xml” works fine but all others “my-custom-postype-sitemap2.xml”, 3, 4 etc… come up as page not found which is why these are showing error messages in Google Webmaster Tools.

    Possible answer here (2nd answer by petervanderdoes): http://wordpress.org/support/topic/plugin-wordpress-seo-by-yoast-error-your-sitemap-appears-to-be-an-html-page

    Exclude your sitemaps from W3TC or possibly other caching plugins.

    I had the same and did as above and it worked.

    1ST > It’s Ok about clearing cache you can do that anytime If you use cloudflare for your CDN add a custom page rule “/sitemap_index.xml” and select baypass cache
    2nd > Make sure you’ve defined already the pages, posts or CPTs to be indexed (avoiding increasing of 404).
    3rd > Go to SEO > Sitemap > Uncheck “enable XML sitemap functionality.” > Save
    4rd > Recheck again XML sitemap functionality > Save (regenerate xml file)
    5th > Resubmit your sitemap_index.xml to webmaster > Refresh > Done
    (note : if still not work you can try to submit your child sitemap.xml only one by one without the parent,ex “page-sitemap.xml”,”post-sitemap.xml” )

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Your Sitemap appears to be an HTML page.’ is closed to new replies.