Support » Plugin: The Events Calendar » Your Site is Experiencing a Technical Issue

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Contributor Andras Guseo

    (@aguseo)

    Hi Dan,

    Sorry this is happening. The very last part of the error message is not familiar at all to me. It looks like some folder on your hosting server going around. So there might be an issue there.

    Could you try to
    – do a full backup of your site
    – deactivate TEC
    – update TEC to the latest
    – reactivate TEC

    And let’s see what this does.

    Thanks,
    Andras

    Hello Andras, thanks for your reply.
    These are the Error details:

    Error Details
    =============
    An error of type E_COMPILE_ERROR was caused in line 35 of the file /var/www/wp-content/plugins/the-events-calendar/the-events-calendar.php. Error message: require_once(): Failed opening required ‘/var/www/wp-content/plugins/the-events-calendar/src/functions/php-min-version.php’ (include_path=’.:/opt/remi/php72/root/usr/share/pear:/opt/remi/php72/root/usr/share/php:/usr/share/pear:/usr/share/php’)

    Please note that I deactivated the plugin, updated to the latest version 4.9.11 > 4.9.12
    and now the site is up.
    This is the second time this has happened since upgrading WordPress to 5.3

    Dan

    Plugin Contributor Andras Guseo

    (@aguseo)

    Sorry this has happened before @danstramer. Weird.

    I’m happy that it is working now.

    I subscribed to this thread, so if this happens again and you leave a note here I’ll get a notification and we can dig into this issue further.

    For now I’ll mark this resolved.

    Cheers,
    Andras

    Hi Andras
    But can you take a look at the error message, it does relate to the TEC calendar.

    An error of type E_COMPILE_ERROR was caused in line 35 of the file /var/www/wp-content/plugins/the-events-calendar/the-events-calendar.php. Error message: require_once(): Failed opening required ‘/var/www/wp-content/plugins/the-events-calendar/src/functions/php-min-version.php’ (include_path=’.:/opt/remi/php72/root/usr/share/pear:/opt/remi/php72/root/usr/share/php:/usr/share/pear:/usr/share/php’)

    Plugin Contributor Andras Guseo

    (@aguseo)

    I did look at it.
    What it means is that it cannot seem to find the following file:
    /var/www/wp-content/plugins/the-events-calendar/src/functions/php-min-version.php

    Not sure if you are still seeing this message. If you do, then log in to your server via FTP and check if that php-min-version.php file exists in the plugin folder or not.

    If yes, then the server had some issue and could not find / access it. Then it is probably a server side issue.
    If the file is not there, then something happened during installation or update. A reinstall or a manual install usually helps.
    A.

    Hi Andras,
    The file does exist.
    But certainly there is a bug of some sort, maybe with WP 5.3 and TEC new versions?

    Dan

    Plugin Contributor Andras Guseo

    (@aguseo)

    Not quite sure what could have happened there and why you initially had the error message, since you don’t have it after the update. We haven’t had any reports with a similar message.

    Maybe the moon was in the wrong phase. ¯\_(ツ)_/¯

    and again a fatal error which caused the site not to load.
    These are the details:

    
    Version 4.9.12 | By Modern Tribe, Inc. | View details | Security Check
     This plugin failed to load properly and is paused during recovery mode.
    
    An error of type E_COMPILE_ERROR was caused in line 35 of the file /var/www/wp-content/plugins/the-events-calendar/the-events-calendar.php. Error message: require_once(): Failed opening required '/var/www/wp-content/plugins/the-events-calendar/src/functions/php-min-version.php' (include_path='.:/opt/remi/php72/root/usr/share/pear:/opt/remi/php72/root/usr/share/php:/usr/share/pear:/usr/share/php')
Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.