Support » Plugin: MultilingualPress » “Your session has expired.” after clicking publish or update on a page

  • Resolved b2marketing

    (@b2marketing)


    I based my new site /en on main site. What I mean is that all the content is “copied” over. That all works nicely.

    When I then go in to edit a page on the new /en site and click update I get a white screen with the “Your session has expired.”. I also get this when creating a new page.

    When I create a new site but no not use your plugin to “copy” the content over then I can create a new page and it works.

    I have tried removing the multisite install completely by removing the code in wp-config, .htaccess and database tables and then after that create new site. Same problem.

    When I deactivate your plugin I still get the problem.

    Have you ever experienced this problem before?

    Thank you

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor Thorsten Frommen

    (@tfrommen)

    Hi there,

    no, sorry, never heard of such a problem before.

    Did I get that right that you can navigate both the front and back end in general, but you cannot visist /wp-admin/post.php or /wp-admin/post-new.php?
    Can you deactivate all plugins other than MultilingualPress and see if this is still the case? If nothing changes, maybe (also) switch to some default theme?

    Could you provide a screenshot of the message?

    Also, what is your MultilingualPress and WordPress version, respectively?

    Best regards,
    Thorsten

    Hi Thorsten

    Thank you for getting back to me.

    I am using latest version of WP 4.6.1 and your plugin 2.4.8

    Here is a screenshot though its not much of a help to you.
    https://www.dropbox.com/s/pn3r1qf1kzqnpkm/Sesson%20Expired.png?dl=0

    Yes that is correct. After clicking update to the post/page then I am directed to /wp-admin/post.php and then I get the Session Expired that you see in the attached screenshot.

    I have tried default theme and deactivate all plugins including yours. So 0 plugins active and yet I get this. Its like the bug is “created” when I do the content clone via your plugin.

    When I created the multisite first time I created it with subdomain but then I removed all traces of the Multisite by doing the same as I wrote in first posts and install with /path. I prefer that for languages. Perhaps that is somehow conflicting.

    Kind regards
    Philip

    Plugin Contributor Thorsten Frommen

    (@tfrommen)

    Hi Philip,

    just to make sure: do you have any dropins and/or MU-plugins installed?
    You see them listed on /wp-admin/network/plugins.php?plugin_status=mustuse and /wp-admin/network/plugins.php?plugin_status=dropins, respectively. Maybe there is something that causes this.

    What I find strange is that WordPress Core does not print Your session has expired. only.
    It should either be Your session has expired. Please log in to continue where you left off., which is displayed on the (forced) login page only, or Your session has expired. You can log in again from this page or go to the login page..

    Can you try to search for what is actually rendering the message?

    Thanks,
    Thorsten

    I found the culprit. It was a plugin. I had deactivated every plugin but I guess I forgot to refresh the page before clicking update. I had 2 tabs open, 1 with the post and 1 with the plugins. Sorry for wasting your time. Tried everything. Moved host etc. Arg. 1 little refresh away from finding the culprit 2 days ago.

    This https://wordpress.org/plugins/genesis-translations/ does not like to be active on the child sites. So if I do not network activate this then it works.

    Thanks for keep trying to help me.

    Plugin Contributor Thorsten Frommen

    (@tfrommen)

    Haha, such things happen. 😀 Glad you’re good now.

    Have a nice day!
    Thorsten

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘“Your session has expired.” after clicking publish or update on a page’ is closed to new replies.