Support » Plugin: BackWPup - WordPress Backup Plugin » ” Your proposed upload exceeds the maximum allowed size”

  • Resolved victorkun

    (@victorkun)


    Issue : BackWPup fails at end when trying to use CURL to transfer our 6GB file to Amazon S3.

    WordPress version 5.1.1
    BackWPup version 3.6.0
    PHP version 7.3.7 (64bit)
    cURL version 7.19.7
    cURL SSL version NSS/3.27.1

    Could it be my php.ini restrictions that prevent this?
    Could it be S3 and some 5GB filesize thing I’ve seen online?

    It is not either of those…because I wrote a PHP script to copy to S3 that used my php.ini.
    This would test both questions -> php -c /etc/php.ini /tmp/cp.php

    S3 is mounted as a directory/partition on our server.

    # cat tmp/cp.php
    <?php
    $fn = ‘./BIG-6GB-FILE.tar.gz’;
    $newfn = ‘/home/MOUNTPOINT/S3/BIG-6GB-FILE.tar.gz’;

    if(copy($fn,$newfn))
    echo ‘The file was copied successfully’;
    else
    echo ‘An error occurred during copying the file’;
    ?>

    The php-script completed successfully and copied to S3.

    So S3 can accept a file bigger than 5GB.
    And our PHP.INI file seems to be fine to allow it as well.

    ===========Here’s a snippet of our log file==================


    [09-Jul-2019 09:55:48] Backup archive created.
    [09-Jul-2019 09:55:48] Archive size is 6.84 GB.
    [09-Jul-2019 09:55:48] 30870 Files with 8.66 GB in Archive.
    [09-Jul-2019 09:55:52] One backup file deleted
    [09-Jul-2019 09:55:52] Restart after 6 seconds.
    [09-Jul-2019 09:55:55] 1. Trying to send backup file to S3 Service …
    [09-Jul-2019 09:55:55] Connected to S3 Bucket “OUR-S3-BUCKET” in us-west-2
    [09-Jul-2019 09:55:55] Starting upload to S3 Service …
    [09-Jul-2019 10:01:13] WARNING: Job restarts due to inactivity for more than 5 minutes.

    [09-Jul-2019 10:03:24] 3. Trying to send backup file to S3 Service …
    [09-Jul-2019 10:03:24] Connected to S3 Bucket “OUR-S3-BUCKET” in us-west-2
    [09-Jul-2019 10:03:24] Starting upload to S3 Service …
    [09-Jul-2019 10:05:05] ERROR: S3 Service API: [curl] 55: [url] https://OUR-S3-BUCKET/OUR-BIG-FILE
    [09-Jul-2019 10:05:05] Restart after 109 seconds.

    [09-Jul-2019 10:05:22] 4. Trying to send backup file to S3 Service …
    [09-Jul-2019 10:05:23] Connected to S3 Bucket “OUR-S3-BUCKET” in us-west-2
    [09-Jul-2019 10:05:23] Starting upload to S3 Service …
    [09-Jul-2019 10:06:54] ERROR: S3 Service API: Your proposed upload exceeds the maximum allowed size
    [09-Jul-2019 10:06:54] Restart after 107 seconds.

    [09-Jul-2019 10:09:10] 6. Trying to send backup file to S3 Service …
    [09-Jul-2019 10:09:10] Connected to S3 Bucket “OUR-S3-BUCKET” in us-west-2
    [09-Jul-2019 10:09:10] Starting upload to S3 Service …
    [09-Jul-2019 10:10:03] ERROR: S3 Service API: [curl] 55: [url] https://OUR-S3-BUCKET/OUR-BIG-FILE
    [09-Jul-2019 10:10:03] Restart after 88 seconds.
    [09-Jul-2019 10:10:05] ERROR: Step aborted: too many attempts!
    [09-Jul-2019 10:10:05] One old log deleted
    [09-Jul-2019 10:10:05] ERROR: Job has ended with errors in 2840 seconds. You must resolve the errors for correct execution.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter victorkun

    (@victorkun)

    Ah, was busting my head on this for the past 3 days…decided to post this question today…but then found my answer today too!!!
    ==============================================================
    Resolved :
    1) In IAM on AWS, ensure the “ROLE” assigned to your EC2 has the “Policy” that grants access to the designated S3 bucket
    2) In IAM on AWS, ensure the IAM User has that “Policy” in their “Permissions” tab
    3) In BackWPup job, use that IAM USer’s [Access key ID/Secret access key] pair in the “To: S3 Service” tab and select the proper bucket is selected in “Bucket selection” drop down.
    4) In BackWPup job, in the “To: S3 Service” tab, ensure the checkbox for “Multipart Upload” is checked.

    That’s what worked for me…

    • This reply was modified 2 years, 4 months ago by victorkun.
    Plugin Support duongcuong96

    (@duongcuong96)

    Hi @victorkun
    Really great to hear that you resloved the issue and thank you very much for sharing the solution to others 😀

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘” Your proposed upload exceeds the maximum allowed size”’ is closed to new replies.