WordPress.org

Support

Support » Plugins and Hacks » Spam Free WordPress » [Resolved] Your plugin update messed up my site

[Resolved] Your plugin update messed up my site

  • This is in the header even after I uninstalled this dumb plugin. Is this how you want to get people to pay for support?

    Simple Comments is the pro version replacement for Spam Free WordPress.
    Get bullet proof spam protection, more features, and support with Simples Comments.
    Until July 31 get 20% OFF Simple Comments. Use COUPON CODE SFWPJUL. Learn more.

    I want this off my site!!!

    http://wordpress.org/plugins/spam-free-wordpress/

Viewing 11 replies - 1 through 11 (of 11 total)
  • esmi

    @esmi

    Forum Moderator

    Try clicking on the “hide” link and, if necessary, refreshing the page.

    OK, the problem was hyper cache. But why the hell do you display this spam on the front page? This plugin is supposed to protect from spam, not be a spam.

    It was shown in the header when viewing my site not logged in. You cannot hide it unless you are logged in. It is WRONG to show this on the front page, but this might have been caused by Hyper Cache running. The plugin should show a warning to disable it during install. Or it was caused by incompatibility with the theme. No idea.

    esmi

    @esmi

    Forum Moderator

    this might have been caused by Hyper Cache running

    Almost certainly. I actually tested the plugin myself and the hide link does work.

    I absolutely agree with belantos. It is completely unacceptable to be displaying any sort of message on the front page of my clients’ sites without any kind of prior warning.

    I will be uninstalling this plugin from all my sites, just as soon as I can get them working again, as I can no longer access my admin areas since today’s update.

    This is absolutely appalling. I’d rather have the Viagra ads, at least they’re below the first screen.

    And I’m not using HyperCache, or any other caching plugin. Also, after clearing it (clicking “hide”) I tried in another browser, and it was still there.

    esmi

    @esmi

    Forum Moderator

    Please post your own reviews, people.

    I have identified the problem with the update that caused this, and emailed the info to the plugin author. I believe the breakage was unintentional. In the meantime, the plugin has been de-listed to prevent any further breakages. When the author fixes the plugin and contacts us, we will re-list it.

    If you are trying to help us fix up the mess your plugin created why on earth do you require what our *budget* is? It is none of your business!!! You can ask this from paying customers.

    Plugin Author Todd Lahman

    @toddlahman

    It’s just a contact form, you know, to contact me directly for help. Do you really think you are being charged, or are you just trying to make a big deal out of everything I say or do because you are upset?

    You are free to refuse my help if you wish, for whatever reasons you come up with, but there is no reason for you to continue flaming me on the forum if you aren’t asking for support.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] Your plugin update messed up my site’ is closed to new replies.
Skip to toolbar