Support » Plugin: Yoast SEO » Your plugin stopped working all of a sudden!

  • Resolved courageous999

    (@courageous999)


    Your plugin was working fine for years but all of a sudden I find out it’s not working today. No per page settings, no menu settings, no “Settings” link on the plugin itself yet it is ACTIVE.

    I’ve disabled and re-enabled it to no avail. I disabled every single other plugin and switched to a 2020 Theme but the result was still the same.

    You guys need to work on making sure your plugin notifies the Admins a lot better than this. Finding out that it is not working at all days later is not acceptable.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Suwash Kunwar

    (@suascat_wp)

    Hi @courageous999,

    We apologize for the trouble you are experiencing with our plugin.

    We expect few more information about your setup. This might help us replicate the issue on our end:

    1. Is Yoast SEO Metabox disappeared from the posts and pages?

    2. Can you confirm you are using the most recent Yoast SEO 15.2.1?

    3. Are all your non-Yoast plugins and themes also updated?

    4. Can you confirm you are using WordPress 5.5.3? You can check by clicking on the W in the top left and selecting About. If you need to update, please check with your host provider. Please know that if you are using an older version of WordPress Core you may experience unexpected behavior with Yoast. This guide explains more: https://yoast.com/why-we-dont-support-old-wordpress-versions/.

    5. Are you seeing any JavaScript errors in your browser console? To know how to check the errors, please refer: https://yoast.com/help/how-to-find-javascript-errors-with-your-browsers-console/

    6. If you see any sort of errors or warnings, can you please write us what they are? If possible, can you take a screenshot that highlights this issue? This would help us investigate the issue further.

    We look forward to your response

    Thread Starter courageous999

    (@courageous999)

    Hi Suwash,

    1) The Metabox is there on both. However, the part of the Metabox that usually lets us set the individual page/post to “no-index” or “no-follow” is missing.

    2) Yes, 15.2.1.

    3) Yes, and like I said, disabling every single other plugin and the theme did not resolve the issue.

    4) Yes, WordPress 5.5.3.

    5) No JavaScript errors in the Console. None on the backend (WP Admin) and none on the Frontend of the site either.

    6) Image 1 shows there’s no “Settings” link under the plugin itself: https://i.imgur.com/xYrVASa.png
    Furthermore, “SEO” is missing from the WP Admin Menu.

    The following image shows the Yoast SEO Metabox on a Page. For some reason the part which usually lets us set the page as “noindex” or “nofollow” is missing.
    https://i.imgur.com/5GCnRuz.png

    All of the above has been tested with all the other plugins switched off.

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    Thanks for sharing all the requested information. Based on the information you provided, it looks like you no longer have an administrator account that has full access to the relevant dashboard. Can you please confirm whether you are running an administrator with full permissions? If yes, can you please confirm whether you are running a 3rd party plugin that allows anyone to change the account role and permission for existing accounts?

    Thread Starter courageous999

    (@courageous999)

    Ah great catch Md Mazedul Islam Khan!

    That was it. Yes I was on a custom Admin role that usually had all the capabilities an Administrator role has but I guess at some point recently your plugin has separated some capabilities because I just went in and found 4 new unchecked Yoast SEO capabilities. Checked those and problem was solved!

    Thanks again for the quick fix.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.