Support » Plugin: Kirki Customizer Framework » Your plugin messed up my theme

  • Resolved kenpb

    (@kennybaldoz)


    Hi, i just want to ask why kirki plugin is messing up with my theme(maxstore pro) and message like this appear in my header “Warning: array_key_exists(): The first argument should be either a string or an integer in /home1/kennybaldoz/public_html/wp-content/plugins/kirki/lib/class-aricolor.php on line 434”.
    Can you please help me regarding this matter? Thanks in advance.

    ken

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Ari Stathopoulos

    (@aristath)

    I’m afraid that’s a premium theme so I don’t have access to it to test.
    I am pushing version 3.0.3 right now which adds an extra check to avoid the issue you’re having. You should be able to get the new version in a few minutes.

    By the looks of it, one of the colors used in your theme-options is improperly formatted which is causing this.

    Since I don’t have access to that theme I’m afraid I can’t properly debug this. I would advise you to review your theme-options and see if there’s anything out of order there.

    If you don’t find any issues there, please contact the theme developer, or send me a copy of the theme so that I may check out what goes on.

    kenpb

    (@kennybaldoz)

    What happened next is all the description of my products become invisible. Please help. Thanks

    Hi @aristath

    We do not use in typography field the “Color” fied, but in the frontend the kirki call default #fff color.

    Plugin Author Ari Stathopoulos

    (@aristath)

    @themes4wp

    We do not use in typography field the “Color” fied, but in the frontend the kirki call default #fff color.

    So is the problem with the typography field? Have you identified the issue?
    I’m afraid I can’t tell what’s going on since I don’t have access to the theme and don’t know what it is that causes this here.
    Can you send me a copy of your theme and instructions on how to replicate the issue you have?
    If I can replicate it, I’ll be able to fix it.

    Yes, the typography field. Still no success to identify the issue.
    It happened only after plugin update on live site with existing content (and enabled theme).
    If I try activate the theme on new website with updated plugin – no issue there

    Plugin Author Ari Stathopoulos

    (@aristath)

    Hmmmmm….
    Can you do a var_dump( get_theme_mod( 'typography_field' ) ); and let me know what the value is?
    Of course replacing typography_field with the actual ID of the field

    Plugin Author Ari Stathopoulos

    (@aristath)

    > If I try activate the theme on new website with updated plugin – no issue there

    So is the conflict limited to this site?
    Or is it for any sites that are updating and are not new installations?

    The issue is not limited only on this site.
    I have updated theme on my localhost and same issue. The typography field generates “color” style that is not defined in the typography option.
    http://recordit.co/Bkpey7mCJB

    array(11) { ["font-family"]=> string(9) "Nova Slim" ["font-size"]=> string(4) "14px" ["variant"]=> string(7) "regular" ["line-height"]=> string(3) "1.8" ["letter-spacing"]=> string(1) "0" ["word-spacing"]=> string(0) "" ["color"]=> string(7) "#ffffff" ["text-align"]=> string(7) "inherit" ["font-weight"]=> string(3) "300" ["font-style"]=> string(6) "normal" ["subsets"]=> array(1) { [0]=> string(5) "latin" } }

    Plugin Author Ari Stathopoulos

    (@aristath)

    That’s weird… The color input in typography controls is only added when the color is defined in the field’s default value as you can see on https://github.com/aristath/kirki/blob/3.0.3/controls/typography/class-kirki-control-typography.php#L310-L315
    I just tested this too just to be sure… seems to be working fine.
    Can you please send me a copy of the theme via a dropbox link or google-docs link or whatever is more convenient for you on aristath at gmail dot com? This way I’ll be able to test this and see where things went wrong…

    In order to replicate the issue I’ll have to edit my theme-options using the previous version of the plugin, and then update the plugin. Right?

    Hi @aristath

    I tried to send you an email yesterday – no success – returned as undelivered. Same today. Contact me on info at themes4wp dot com please.

    Plugin Author Ari Stathopoulos

    (@aristath)

    For reference, there’s ticket on https://github.com/aristath/kirki/issues/1405 too

    Plugin Author Ari Stathopoulos

    (@aristath)

    A possible fix for this has now been committed on github, if you want you can test using the development version of the plugin from https://github.com/aristath/kirki (direct-download link: https://github.com/aristath/kirki/archive/develop.zip)

    If it doesn’t work immediately, try opening the customizer, making a change in the typography control (any change) and save it.

    Let me know if that works!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Your plugin messed up my theme’ is closed to new replies.