Support » Plugin: MultiPay » Your plugin has many PHP code warnings!

  • ResolvedPlugin Author The Easy Web Co.

    (@etalented)


    Using PHP 7.2, your plugin generates all these warnings:
    Warning: Declaration of WorldpayPayments::onLoad($parent, $api) should be compatible with PaymentBase::onLoad() in /Applications/MAMP/htdocs/website/wp-content/plugins/multipay/PaymentsAPI/worldpay/WorldpayPayments.class.php on line 98

    Warning: Declaration of AmazonPayments::onLoad($parent, $api) should be compatible with PaymentBase::onLoad() in /Applications/MAMP/htdocs/website/wp-content/plugins/multipay/PaymentsAPI/amazon/AmazonPayments.class.php on line 240

    Warning: Declaration of PaypalPayments::onLoad($parent, $api) should be compatible with PaymentBase::onLoad() in /Applications/MAMP/htdocs/website/wp-content/plugins/multipay/PaymentsAPI/paypal/PaypalPayments.class.php on line 173

    Warning: Declaration of StripePayments::onLoad($parent, $api) should be compatible with PaymentBase::onLoad() in /Applications/MAMP/htdocs/website/wp-content/plugins/multipay/PaymentsAPI/stripe/StripePayments.class.php on line 116

    Notice: Undefined index: custom in /Applications/MAMP/htdocs/website/wp-content/plugins/multipay/multipay.php on line 1579

    Notice: Undefined index: mode in /Applications/MAMP/htdocs/website/wp-content/plugins/multipay/PaymentsAPI/worldpay/WorldpayPayments.class.php on line 39

    Notice: Undefined index: client_key in /Applications/MAMP/htdocs/website/wp-content/plugins/multipay/PaymentsAPI/amazon/AmazonPayments.class.php on line 47

    Notice: Undefined index: handle-colours in /Applications/MAMP/htdocs/website/wp-content/plugins/multipay/multipay.php on line 1262

    Notice: Undefined variable: bg in /Applications/MAMP/htdocs/website/wp-content/plugins/multipay/multipay.php on line 1266

    Notice: Undefined index: use_custom in /Applications/MAMP/htdocs/website/wp-content/plugins/multipay/multipay.php on line 1267

    Can you please resolve??

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Your plugin has many PHP code warnings!’ is closed to new replies.