WordPress.org

Support

Support » Installation » Your PHP installation appears to be missing the MySQL which is required for Word

Your PHP installation appears to be missing the MySQL which is required for Word

  • Just thought I’d post my resolution to this problem. I noticed ALOT of posts on this subject with varying results , some a little vague and non-conclusive. I have been trying to figure out how to get WordPress to work on my current setup for the last 2hrs and finally cracked it. I thought I’d post just incase any one else is having the same problem and finds this helpful.

    Summary :
    Windows Server : 2003 / IIS6.0
    PHP Version : 5.1.2
    MySql Version : 5.0.20a

    Resolution :
    + Ensure your environment variables include c:\php ( I also added c:\php\ext )
    + Ensure php5isapi.dll is enabled in your web service extensions
    + Ensure php5isapi.dll is enabled in your ISAPI filter list at the root of your website, also check that php5isapi.dll is enabled in the application configuration on your virtual directory that your using for WordPress

    The imporant bit :
    Several modifications need to be made to the php.ini file as php5.0 does not include automatic support of MySql.

    Under the “Dynamic Extensions” section of the php.ini file.

    + Ensure that; extension_dir = “./ext/”
    + Ensure that; extension=php_mysql.dll

    Are both set.

    NOTE: If your running php/Microsoft SQL, AND php/MySQL alongside each other on the same server, DO NOT enable extensions for php_mssql.dll and php_msql.dll, leave these commented out. Don’t ask me why, just when I enabled them it blew up a php/Microsoft SQL application I was running.

    I also had to copy php.ini to c:\windows DESPITE it being declared in my environment variables. Odd *shrug!*

    Anyway… Success !!! yay! Another happy Word Press user.

    Hope this helps some of you out.

  • The topic ‘Your PHP installation appears to be missing the MySQL which is required for Word’ is closed to new replies.
Skip to toolbar