Support » Plugin: Wordfence Security - Firewall & Malware Scan » Your PHP installation appears to be missing the MySQL extension which is require

  • Resolved matlidigital

    (@matlidigital)



    Hello,

    Last night i got this message on all of my wordpress websites, after too much efforts in the server i asked support from the cPanel technical expert and after 1 hour he successfully found the following issue below:

    ====
    <IfModule mod_suphp.c>
    suPHP_ConfigPath ‘/home/gouin/public_html’
    </IfModule>
    ====

    This line is generated by wordfence and it made all website to show “FAKE” error message to confused the webmasters, because what this message says is “Your PHP installation appears to be missing the MySQL extension which is require” problem in mysql or mysql driver within php installation of 5.6 5.5 5.4 7.0. i have checked all php version but this issue is same on all.

    I want the developer to look into this issue and try to fix this ASAD as i believe wordfence can generate this line again.

    let me know if you need more information i.e logs, but i want to clear you that there was no error logs generated, this was the very silent issue.

    CentOS 7
    PHP 5.4. 5.5 5.6 7.0
    MySQL 5.6
    Worfnce latest
    wordpress latest

    https://wordpress.org/plugins/wordfence/

Viewing 15 replies - 1 through 15 (of 17 total)
  • I had the exact same problem after an autoupdate (i think), removing those lines fixed it. Not to happy about it!

    I also had this problem on all my WordPress sites.
    The problem exists when then following conditions exist.
    cPanel server
    easyapache 4 in use
    suPHP in use
    WordPress website
    WordFence Firewall enabled

    The change that broke things is an EasyApache 4 update. See cPanel Forum Thread

    To fix it WordFence Firewall must be disabled. This is tricky as the sites are inaccessible with a browser.
    Use an FTP client or your Web Hosting File Browser to edit .htaccess file.
    The whole…
    # Wordfence WAF block

    # END Wordfence WAF block
    block must be deleted.
    Save. (and upload if using FTP)
    Normal server function should now be restored.
    Log in to WordPress backend and disable WordFence Firewall. Save.

    Work around so as to be able to use WordFence Firewall with this server configuration might be to Have a complete copy of php.ini at the web root level.

    On further inspection in the WordPress admin => WordFence firewall
    after I re-enabled the firewall for one site it showed that the
    Protection Level: Extended Protection
    It was the extended protection that wrote the htaccess lines, added the user.ini and the wordfence-waf.php files.
    At the bottom of the firewall admin page is a button called “Remove Extended Protection”.
    I clicked this to initiate the removal process. It was slow, but succeeded. I then clicked the same button, now with a different name “Enable Extended Protection”. This also succeeded. It re-created the user.ini and the wordfence-waf.php files.
    It also added lines to the htaccess file, but this time without the suPHP_ConfigPath line which was the trigger of this problem.
    Both front end and back end of this site are now accessible, so it appears the WordFence Firewall is operating successfully in Extended Protection mode without issue.

    Hey Guys,

    Sorry for all the trouble! Seems like you guys are right on track. I think the best way to handle the problem right now is to manually remove the

    <IfModule mod_suphp.c>
    suPHP_ConfigPath '...'
    </IfModule>

    section of code from the .htaccess file. Since version 6.1.9, Wordfence no longer needs, or adds, this block of code.

    However, if you continue to have problems, you may need to manually remove the Wordfence Firewall, similar to what wallyO did, by following these steps: https://docs.wordfence.com/en/Web_Application_Firewall_FAQ#How_can_I_remove_the_firewall_setup_manually.3F.

    You will not experience these issues after re-enabling / re-installing Wordfence Firewall. We have found other, better ways to handle servers using suPHP.

    Again, sorry for the trouble. Feel free to add any information that may help us troubleshoot.

    Thanks wallyO!

    Hi There,

    I’m using wordfence and I am also getting the same problem.

    I’ve tried the solution outlined above but my .htaccess file seems to display something different. Am I looking at the correct solution? Not sure where to go from here.

    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule .* - [E=noabort:1]
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    
    • This reply was modified 1 year, 10 months ago by  hypeon.

    You clearly have a different problem.
    If the problem started when you installed WF or changed a WF setting then use FTP to delete WF.
    See if fixed. (But i don’t think that will fix it)
    You have a non-standard htaccess.
    A standard is…

    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    

    Try that.

    As the issue is not what this thread is about, you should open a new thread with the most obvious issue or symptom you are experiencing in the subject line.

    Hello

    I faced the same problem with kivuyo but when checked htaccess, there was no line such as suPHP_ConfigPath ‘…’

    To solve the problem on question, I decided to harden php protection by installing “suhosin” from cpanel, php version and the problem was solved.

    I am using php version 5.6

    • This reply was modified 1 year, 9 months ago by  lembu.
    • This reply was modified 1 year, 9 months ago by  lembu.
    • This reply was modified 1 year, 9 months ago by  lembu.

    i have exactly the same problem can u plz tell me where to find this

    <IfModule mod_suphp.c>
    suPHP_ConfigPath ‘/home/gouin/public_html’
    </IfModule>

    tried looking htacces but did not find it anyone please

    @alijan1 do you have WF extended protection? From what I understand, you should be able to disable extended protection, then reenabled it, and it should take care of the code, let us know if that works. Unless you are locked out, then you will have to get into your htaccess file, which should be in the root directory of your hosting account.

    thank you so much problem solved.

    I also have

    `Your PHP installation appears to be missing the MySQL extension which is required by WordPress.

    however, I do not have Word Fence.

    I have restored my site from before trying to update WordPress to 4.7.3

    Hi,

    So we just had this problem.

    WF, why can’t you just automate fixing that piece of code so people don’t have this issue?

    Thanks

    I am getting a message quoting “Your PHP installation appears to be missing the MySQL extension which is required by WordPress.” whenever i try to login into my wp-admin of my website i.e., freakytechs.com.
    what should i do??

    Our host was able to switched our php version back to native which along with a few other things got us back to where we needed to be.

    Gayatri

    (@the-muffin-top)

    My website was working just fine till an hour ago, and then I get this message on the screen: Your PHP installation appears to be missing the MySQL extension which is required by WordPress.

    I’m not sure why this has happening, maybe the recent wordpress update? I have no technical knowledge and I don’t understand how to fix it. Please help!!

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Your PHP installation appears to be missing the MySQL extension which is require’ is closed to new replies.