Support » Localhost Installs » Your PHP installation appears to be missing the MySQL extension which is require

  • Resolved jrbbldr

    (@jrbbldr)


    OK, the previous posts on this topic are all CLOSED so I need to make this new posting.

    I looked over the previous postings and tried many, many of the suggestions and still have not found how to get things working.

    Environment:
    OS: Win 7 Home Premium
    Apache 2.4 (in its own directory: C:\Apache24)
    ‘root’ directory configured to be C:\Apache24\wwwroot
    PHP 5.5.6 (in its own directory: C:\Applications\PHP)
    MySQL 5.6.14.0 (in its own directories under: C:\Program Files (x86)\MySQL)
    WordPress 3.7.1 (in directory: C:\Apache24\wwwroot\WordPress)

    The MySQL seems to be working just fine.
    The Apache + PHP appears to be working OK
    But when I attempt to launch WordPress I get the error message:
    Your PHP installation appears to be missing the MySQL extension which is required

    Within php.ini I have
    extension_dir = “c:\applications\php\ext”
    and I have the extensions uncommented:
    extension=C:/Applications/PHP/php_mysql.dll
    extension=C:/Applications/PHP/php_mysqli.dll

    Any advice and/or suggestions would be greatly appreciated.

    Thanks

Viewing 15 replies - 1 through 15 (of 42 total)
  • I am not sure if WordPress has been tested/developed for PHP5.5.6…Contact the host you will or do use and ask what version they provide (and the MySQL and Apache versions also) and then setup your localhost with those. Something about the mysqli not working in 5.5+

    You may also want to seek support in this section:

    Localhost Installs

    The mysql extension is deprecated in PHP 5.5, but will be removed in the future as a starting point. Also make sure you added PHP to your system path environment variable.

    extension=C:/Applications/PHP/php_mysql.dll
    extension=C:/Applications/PHP/php_mysqli.dll

    When un-commenting the extensions in php.ini, the path would not normally be required as part of the extension…

    “If you only provide the name of the extension, PHP will look for it in its default extension directory”

    If you included the full path (or an incorrect path) as part of un-commenting the extension, you might try this instead.

    extension=php_mysql.dll
    extension=php_mysqli.dll

    Wait how about

    extension=C:\Applications\PHP\php_mysql.dll
    extension=C:\Applications\PHP\php_mysqli.dll

    / = server
    \ = local

    ?

    Thanks for the suggestions.

    I am not sure if WordPress has been tested/developed for PHP5.5.6

    I am looking forward to starting to work with WordPress, but I’ve been working for about a week now to get the ‘foundational’ software pieces (MySQL, PHP, Apache) all working in concert and it has been very challenging (frustrating??).

    There are just too many un-compatible versions of each out there and no ‘hard and fast’ definitive guideline to reference.

    Regardless, I’ll give these suggestions a try and get back with the results.

    Well I changed the slashes (/ to \) used in the extension configurations within the php.conf file and did a Restart of Apache.

    I then did a Apache + PHP test and everything looked OK
    (phpinfo() was displayed fine)

    But when I attempted to launch WordPress, I got the same error message:
    Your PHP installation appears to be missing the MySQL extension which is required

    Now I’ll try removing the path designation in the extension configurations and rely on the extension_dir setting.

    Back in a few with the results.

    Thanks

    @pioneer Valley Web Design

    / = server
    \ = local

    ?

    UNIX: “/path1:/path2” Windows: “\path1;\path2”

    I think you’re basically on the right track, but I doubt it would make any difference without including the extension directory.

    @jrbbldr

    Putting aside the reasons for a forward slash or a backslash, I think the paths would still need to match (and be valid). It looks like the ‘ext’ directory set in the extension_dir directive has been omitted from the path being appended to the extensions.

    extension_dir = "c:\applications\php\ext"

    extension=C:/Applications/PHP/php_mysql.dll
    extension=C:/Applications/PHP/php_mysqli.dll

    I’m sure I’ve missed some glaringly obvious issue, but at first glance the missing ‘ext’ directory in the extension path might cause an initial stumbling block.

    Thanks for the reply.

    (BTW: Oops – I meant to say PHP.INI instead of PHP.Conf above.)

    I already did have the extension_dir slashes correct for localhost use.
    extension_dir = “c:\applications\php\ext”

    By removing ALL Pathing from the individual extension configurations
    Such as: extension=php_mysql.dll
    and relying solely on the extension_dir did indeed change the symptoms.

    Now when I attempt to launch WordPress’s Index.php I no longer get the same error message.

    Instead now my browser (both IE & Firefox) shows perpetual Connecting… and the status bar shows Waiting for localhost…
    It gets no further. I waited a full 5 minutes with no change.

    Note – localhost test -> running Apache + PHP test still shows phpinfo() just fine.

    So something is different.
    Whether it is closer to working or not I cannot say.

    Any further suggestions?

    Thanks

    esmi

    (@esmi)

    Forum Moderator

    Is this intended to be a production server or just a development server?

    This is to be a Development server and (more importantly) a Learning environment.

    esmi

    (@esmi)

    Forum Moderator

    In that case, can I suggest that you consider using EasyPHP? You’ll find instructions on how to set it up on http://quirm.net/2011/05/05/installing-wordpress-locally-using-easyphp/

    It’s far easier to set up than WAMP or XAMP.

    You might also try returning the extension_dir directive back to it’s default just to rule out any possible conflict there, then restart apache and see if the symptom changes. The default is;

    extension_dir = "ext"

    [edit] …and I’m with esmi, if you are more interested in working with WordPress than dealing the hassle of local server configuration! 🙂

    Did you restart the local server after making changes?

    Thanks for the suggestion.

    I see where it says:
    EasyPHP is a WAMP package that includes PHP, Apache and MySQL

    So I would have to UnInstall my currently installed Apache, MySQL, and PHP which individually appear to be working OK so that the new versions could be installed?

    I also see where it says:
    This version supports :
    PHP 5.5.x / 5.4.x / 5.3.x / 5.2.x VC9, VC10 and VC11
    This version includes :
    Apache 2.4.4 VC11 | MySQL 5.6.11 | PhpMyAdmin 4.0.3

    Which are the versions that I am running now.

    I guess that if no one else have any better suggestions, it is worth a try.

    Thanks

    esmi

    (@esmi)

    Forum Moderator

    So I would have to UnInstall my currently installed Apache, MySQL, and PHP which individually appear to be working OK so that the new versions could be installed?

    Yes. I think you might find this a lot quicker than trying to sort out the various issues in your current local server. Takes about 15 mins on average to get EasyPHP up & running.

    Thanks

    OK, its worth a try.

    BTW: I did not use WAMP or XAMP to install/configure anything. Instead I did the various ‘raw’ installations and configurations – following the instructions on WordPress.org and with ApacheLounge.com forum help.

    One thing I ran into before with trying to use a pre-packaged software ‘suite’ to support WordPress on Windows (I don’t remember if it was

      Instant WordPress

    or something else) was that configuration ‘uniquenesses’ caused things to run in a somewhat non-standard manner.

    So when I needed support on “HOW DO I DO THIS…” stuff, the existence of the ‘uniquenesses’ made my installation and efforts hard to get help on (nothing worked ‘quite’ like others would have expected).

    Should I expect the same from this package?
    Or is this one put together in a ‘standard’ manner?

    Thanks

Viewing 15 replies - 1 through 15 (of 42 total)
  • The topic ‘Your PHP installation appears to be missing the MySQL extension which is require’ is closed to new replies.