Support » Installing WordPress » Your PHP installation appears to be missing the MySQL extension which is require

  • These are my specifications:

    WordPress version: 2.7.1
    IIS webserver: 5.1
    Mysql: 5.1

    I am trying to install wordpress on my local machine and everytime I go to
    localhost/wp-admin/install.php I get the following error:
    Your PHP installation appears to be missing the MySQL extension which is required by WordPress.

    I have modified my wp-config according to the database created by me on.

    I looked around allposts and found some of the common things mentioned. These are some of the things Ihave tried.

    1. Removed the ; from extenion=php_mysql.dll and mysqli.dll in php.ini
    2. Changed the extension_dir= (location where php is installed)
    3.Made sure the IUSR_computername have permission for the php folder on my local drive
    4.reinstalled wordpress couple of times
    5.restarted IIS service at every step to make sure I am not missing anything
    6.Made sure that the required mysql.dll amd mysqli.dll are present in php/ext folder
    7.copied the libmsql.dll from \mysql\bin folder to \php

    But still I get the same error
    can anyone please let me knowif there is something I can do more
    or can throw some more light on this.

    Thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Your PHP installation appears to be missing the MySQL extension which is require’ is closed to new replies.