Support » Plugin: Polarsteps Integration » Your last saved step is “, “

  • Resolved adetaylor76

    (@adetaylor76)


    I have installed the plugin but I get ‘ Your last saved step is “, ” ‘ on the configuration page, as well as a blank when inserted into a sidebar.

    I have tried with a trip ID, and with default of ‘0’. I have verified the cron job as having run.

    Any troubleshooting steps?

    Thanks

Viewing 9 replies - 1 through 9 (of 9 total)
  • I have the exact same thing. I’m following this!

    Plugin Author npersonn

    (@npersonn)

    Hi,

    looks like you both got the same issue. I recently updated the plugin to fetch the latest steps when saving. Looks like this step did not work for both of you.

    Maybe you can give me more information about the issue. Any of you have access to the error-logs? Which version of wordpress and php are you’re using?

    Please note as well, the plugin requires you to have at least one public trip. Otherwise the script cannot fetch any data.

    Another common mistake is that the username is wrong. To check this, go to your polarsteps profile and copy the username from the Url. For example https://www.polarsteps.com/username. Please note it is case-sensitive.

    • This reply was modified 4 years, 3 months ago by npersonn. Reason: Added more common issues
    Thread Starter adetaylor76

    (@adetaylor76)

    Hi,

    Thanks for the prompt reply, here’s what you’re looking for:

    WP version: 4.9.4–en_GB
    PHP version: 5.6.31

    I also made my trip public, then ran the cron again. Same issue.

    What is the location of the error logs, I’ll fetch them down for you.

    • This reply was modified 4 years, 3 months ago by adetaylor76.
    Plugin Author npersonn

    (@npersonn)

    Ok, would you mind to send me your Polarsteps account? Then I can check on my side with that account as well.

    On linux the php-error log is typically in /var/log/httpd/error_log or /var/log/apache2/error.log. But could be somewhere else depending on your configuration. If you’re on a managed environment and don’t have access to these folders. Usually, there’s a place in the management console, where the errors (logs) are shown.

    Thread Starter adetaylor76

    (@adetaylor76)

    ID is AdeTaylor. I’ll speak to hosting company about the log.
    Thanks

    Plugin Author npersonn

    (@npersonn)

    I think the issue is clear. As I mentioned earlier:

    the plugin requires you to have at least one public trip. Otherwise, the script cannot fetch any data.

    Please create a trip on polarsteps and add one step. You can do this as well manually. If this is done, to back to the settings and save your username again. The created step should now be shown in the widget.

    On my end, I’ll ship in the next couple of days an update, which is giving better User feedback. Apparently, this situation was not clear from the documentation / error messages.

    Thread Starter adetaylor76

    (@adetaylor76)

    Ah, I think I had made my profile public this morning, instead of the trip!
    I’ve fixed that now, but it still doesn’t seem to be working, even with a public trip. Can you try again please?

    Plugin Author npersonn

    (@npersonn)

    On my development machine it now works. But this does not mean something πŸ˜‰ http://res.cloudinary.com/dyk7fxmgp/image/upload/v1521437963/Unbenannt.png

    Can you try again or try to send the error-logs? As mentioned, I’ll update the current version with better user-feedback in cases like yours.

    Plugin Author npersonn

    (@npersonn)

    Closing this topic now.
    I recently pushed the version 0.3.4 which is more verbose on errors described above.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Your last saved step is “, “’ is closed to new replies.