Support » Plugin: Really Simple SSL » “Your Key and Certificate directories are not properly protected.” issue

  • Resolved ncgyber

    (@ncgyber)


    I am not professional, so I might not know what I am doing..

    At first, I tried to obtain SSL certificates using RSSSL, but couldn’t complete installation because my website is running on AWS Lightsail, which I have to install certificates manually.

    So, I deleted every file that RSSSL created when installing SSL and installed SSL using bncert-tool and it was activated successfully.

    However, RSSSL keep creates empty directories(.well-known, ##########) and keep shows me the warning.

    How do I make RSSSL stop making directories and warnings?

    • This topic was modified 1 year, 4 months ago by ncgyber.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    This is because the plugin has completed the generation, which automatically sets an option “generated by RSSSL” to true. To reset this, you can add

    update_option( 'rsssl_le_certificate_generated_by_rsssl', true );

    to your functions.php. Then load your site. Then you can remove this line.

    The plugin now won’t load the Let’s Encrypt library anymore.

    Thread Starter ncgyber

    (@ncgyber)

    @rogierlankhorst

    It is still creating directories.

    Is it perhaps?:
    update_option( 'rsssl_le_certificate_generated_by_rsssl', false );

    • This reply was modified 1 year, 4 months ago by ncgyber.
    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    So sorry… Yes, you are correct.

    Thread Starter ncgyber

    (@ncgyber)

    @rogierlankhorst

    Thanks. RSSSL is no longer creating directories,
    but it is still showing warning message “Your Key and Certificate directories are not properly protected.”

    Do I need to take extra action?

    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    You can remove that one by adding
    delete_option( 'rsssl_create_folders_in_root' );

    These will be added to a reset option soon, to allow an easy reset of these options. Thanks for taking the time to report the issue.

    Thread Starter ncgyber

    (@ncgyber)

    @rogierlankhorst

    Thanks a lot. All issues are resolved.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘“Your Key and Certificate directories are not properly protected.” issue’ is closed to new replies.