Support » Fixing WordPress » your host may have disabled the mail() function

  • Resolved Orbitor


    I am not sure when exactly this started but I get this error when trying to retrieve passwords:

    your host may have disabled the mail() function

    I have looked around extensively on the boards and:

    1. I have verified that all mail functions are available and active on my host machine.

    2. I have no recent comments and do not use the comment plugin Relish

    3. I am able to log in as admin with no problems

    Have tried these plugins with no good results. I tried with several smtp servers with same negative results:
    Coffee2Code wpPHPMailer
    WP Mail SMTP

    Have read and followed directions on the post on

    Does anyone have any further suggestions or ideas for how to further troubleshoot this problem?

    Are there any ways to check for corruption in my database?

Viewing 8 replies - 1 through 8 (of 8 total)
  • I have the same problem, on two clean installs of 2.3.1. One of these was installed with Fantastico, the other manually.

    Both happen to be hosted at Bluehost, but I have another site on the same domain that is sending mail successfully.

    Any help would be appreciated.

    I should add that the site that is sending mail successfully is not running WordPress.

    Orbitor – I have fixed this on both my installations by creating an e-mail account for wordpress@domain-name. This is a different e-mail account to that setup in Options > General Options.

    Hopefully the same fix will work for you.

    thenarv – I am not sure I understand. I already have setup in General Options. Are you saying I should set up another one?

    BTW, I have tried the Google smtp service with the smtp plugins with the same results!!!

    I am running 2.3.1

    It was working fine at some point earlier but I don’t have a recent enough backup to try (I know, I know….).

    Oh, I should also mention that my contact form and my newsletter plugin are both sending email just fine!!! It’s just the core wordpress install that is acting up.

    For some reason, the e-mail generated for retrieving lost passwords is being sent from account wordpress@domain, and not what I have setup as the admin e-mail account in the settings (which happens to me website@domain).


    Holy cow it worked it worked it worked! Thanks thenarv!

    Thanks! This worked.

    Just to make it clear for anyone else with the problem:

    Under >Options >General >E-mail Address

    Change the account to “”. And make sure you create an actual e-mail/alias account for that address in your domain management tools. I used to have a Gmail address as my account address and I’m guessing maybe that field needs to be filled by something with your domain in it? (And that it doesn’t necessarily need to be “webmaster? I’m too lazy to test this.)

    Also, to add a data point, I’m hosted on Bluehost.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘your host may have disabled the mail() function’ is closed to new replies.