Support » Plugin: IndieAuth » Your have entered a valid Domain, but you have no account on this blog.

  • I activated IndieAuth and was able to link it to GitHub, but when I try and login to my WordPress admin I get the following message if I leave out the username and password:

    Your have entered a valid Domain, but you have no account on this blog.

    How do I associate my self hosted WordPress account with what IndieAuth is looking for? The message offers no help link and the plugin doesn’t have any settings.

    TA

Viewing 7 replies - 1 through 7 (of 7 total)
  • Based on what I see at your site it looks like you may have discovered the answer, but for the benefit of others, You’ll need a few things to make it work:

    • You should have the URL of your domain name set in the URL field of your Public Profile on Github. (Inspecting the URL element on your profile page will reveal that it’s wrapped with a rel=”me”.)
    • The homepage of your site should have a rel=”me” link pointing to your github account. eg: <a rel="me" href="https://github.com/USERNAME">Github</a> or if you don’t want it to be visible <link rel="me" href="https://github.com/USERNAME">

    Now when you try to log in, you can just put your URL into the login box. You’ll be redirected to the IndieAuth site which will scan your site for the rel-me links and present you with options for logging in based on the compatible sites (Twitter works well too, though you can also use email and SMS among other options). Click on the github button and if you’re already logged in via github you’ll be redirected to your website as logged in.

    Plugin Author Matthias Pfefferle

    (@pfefferle)

    Thanks @chrisaldrich for the support!

    @pacifika It seems that you have set up everything quite good so far. What seems to be missing is the correct URL in your WordPress user profile. To match a user, the plugin checks the URL you used to login, with the URLs (‘Website’ filed in the profile settings) in the profiles of your Blogs users.

    Thanks gents for your help. It’s still not working and everything you have mentioned in this thread I’ve verfied.

    I understand you’re not here to support individual implementations 🙂 but for future reference I’ve screenshotted the process – The login fails for both GitHub and Twitter.
    https://postimg.org/gallery/y32whfvi/

    Plugin Author Matthias Pfefferle

    (@pfefferle)

    @pacifika Can you add a screenshot of the “edit profile” page of WordPress? You have to add “vandragt.com” as Website of your user.

    Added to the gallery link (new link below). I just noticed that I am not user 1 (I am 16) but it is a single author blog with one administrator and I verified the default author is set to the user I am wanting to login with (svandragt).

    https://postimg.org/gallery/1i4bty4ym/

    • This reply was modified 1 year, 4 months ago by  Sander. Reason: gallery link changes when files are added

    Sorry I am user 1 it was the ordering of the users in WordPress that confused me.

    Plugin Author Matthias Pfefferle

    (@pfefferle)

    OK, then you have found a bug! Can you please also file it on GitHub (https://github.com/pfefferle/wordpress-indieauth), so I don’t forget about it 😉

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Your have entered a valid Domain, but you have no account on this blog.’ is closed to new replies.