Support » Plugin: Contact Form 7 » your-email is not being captured

  • Resolved inspired888

    (@inspired888)


    Hi there,
    I’ve recently updated Contact Form 7 to the latest version (as of today), from whatever was latest in May 2017.

    Since doing so, the [email your-email] field is not being captured.

    I have two instances of it embedded in two mutually exclusive conditional groups. Here is the relevant template coding:

    [group email-conditional]
          <div style="clear:left;padding-top:10px;">
            <label> Your Email *
            [email* your-email] </label>
          </div>
          [/group] 
    
          [group email-conditional-2]
          <div style="clear:left;padding-top:10px;">
            <label> Your Email (for ease of communication, please provide if you have one)
            [email your-email] </label>
          </div>
          [/group]

    Are there any obvious reasons why this is not working?

    I input the email address, but it comes up blank in the Mail sent out to site owner, and the Mail 2 does not send to the form submitter.

    Thanks,

    Jonathan

Viewing 2 replies - 1 through 2 (of 2 total)
  • What I’ve since figured out is this. It would appear CF7 can’t deal with my form template using the same field twice. I don’t recall that being an issue a year ago, but for sure seems to be the case now. So I’ve gone about constructing my form in a more convoluted way, which seems to now be working fine.

    Hi Jonathan,

    I’m not 100% sure what is going on, but it does appear that you are using another plugin for Conditional Fields given your [group email-conditional] tag. Perhaps with the latest update, this other plugin has been affected and has yet to respond with a fix. Maybe try messaging their forum as well to see if anyone has a better solution than convoluted form syntax.

    Good luck!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘your-email is not being captured’ is closed to new replies.