Support » Plugin: WP Super Cache » Your cache directory () did not exist

  • Resolved WP Monkey

    (@scdesmond)


    I’m now getting an error and WP Super Cache is not running. This notice displays on the plugin page:

    WP Super Cache is disabled. Please go to the plugin admin page to enable caching.

    And then when I go to the WP Super Cache – Setting page this error displays.

    Error: Your cache directory () did not exist and couldn’t be created by the web server. Check permissions.
    Cannot continue… fix previous problems and retry.

    I’ve checked the permissions on folders and files, and it seems fine. However the site was setup with Wordfence and Sucuri by a former webmaster. I looked through all the settings to see if it was blocking something or if I could whitelist WPSC to no avail.

    Suggestions?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Donncha Ó Caoimh

    (@donncha)

    Is $cache_path set in wp-content/wp-cache-config.php ?
    It should probably be set to WP_CONTENT_DIR . '/cache/'.

    But even if it were not, the plugin is supposed to fill in that default, so it shouldn’t be blank at all.

    Hi, thanks, I had this issue too so just to let you know this worked for me. In my case, I had a full cache path set but I think it was missing the sub-directory. Changing it to the above got it working again.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Your cache directory () did not exist’ is closed to new replies.