Support » Plugin: WP-DBManager » Your backup folder MIGHT be visible to the public

  • Resolved Stergos


    Hi, I use 3.2.1 WP version I successful install the plugin and I do every step is required as described to installation notes but I still get this error “Your backup folder MIGHT be visible to the public”. I already move ,rename and test the .htaccess from wp-dbmanager to wp-content/backup-db.

    The permissions of backup-db folder is 770 all “public permissions” is unchecked!

    404 error is normal right?

    Everything is working like auto create DB, email function and restore.

    Any ideas?

Viewing 7 replies - 1 through 7 (of 7 total)
  • esmi


    Forum Moderator

    Try moving the backup folder to outside of your web document root.

    If I move this folder the plugin will still work?

    Can you suggest me a path to place the folder?

    I try it and nothing change!

    Here what I did: After I check that everything is working and make sure that the backup folder is not public I delete add_action('admin_notices', 'dbmanager_admin_notices'); on line 191 from the “wp-dbmanager.php.”

    Thanks anyway, working fine!!!

    It might not be the best idea to edit the plugin’s core files, next time you upgrade the plugin you may lose those changes if the file is replaced.

    I just resolved this issue a few minutes back, it’s dead simple to do. Easiest way is using FTP access. Assuming you have WordPress installed to the root, follow these steps:

    • Navigate to “/wp-content/plugins/wp-dbmanager” and download “htaccess.txt” file
    • Navigate to “/wp-content/backup-db” and upload “htaccess.txt” file
    • Rename to “.htaccess”

    When you refresh your admin page in WordPress the warning will be gone. This won’t affect your backups, manual and scheduled backups still work perfectly.

    I’m having the same problem with WP 3.2.1 and plugin v2.6.3 and have been using the plugin for quite a while. I can’t get the warning to go away. I even deleted the plugin and the backup folder completely then reinstalled, moved and renamed the htaccess file and still getting the warning. Anyone else seeing the same?

    Make sure your server has htaccess protection enabled!
    I ran into the same issue, moved the file, renamed it to .htaccess, and still had the issue… Went to my host server, configured /wp-content/backup-db/ for password protection and no more error!

    Good luck to you 🙂

    In my case, I set the “Path to Backup” to a directory outside of my web document root, so the public can’t hit it in any possible way. Yet, I’m still seeing the warning. There’s no point in placing an .htaccess file in a non-public directory.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Your backup folder MIGHT be visible to the public’ is closed to new replies.