WordPress.org

Support

Support » How-To and Troubleshooting » Your attempt to edit this post: “abc” has failed !!!

Your attempt to edit this post: “abc” has failed !!!

  • Your attempt to edit this post: “abc” has failed.

    Please try again.

    when I post a new article (I have clicked the “published”),it shows that, and the article goes to Drafts ,it can’t be published.

    what’s the matter? How can id do it?

    thanks a lot !!!

Viewing 15 replies - 1 through 15 (of 20 total)
  • It all depends on the permissions the Site Admin gives you as a user.
    On the other hand, if you’re site admin, then you’ve got a problem. What version are you using? Did you just upgrade or did you just add a plugin or delete one?

    WP Super Cache has been deactived,All in One SEO Pack is activing now only.

    I upgrade the blog to wordpress 2.6.2 ,Permalinks is Custom Structure :/%category%/%postname%.html

    thanks.

    Also having this problem on my WP 2.7 install.

    I disabled all plugins but the problem still exists. As suggested in earlier posts on this forum disabling autosave works and lets me publish again. But it shows me a javascript error in IE7. I didnt notice any js errors in Firefox though, but the gross of my editors use IE7 so i want that working flawlessly. I also didnt notice ANY errors posting with FF at all. With or without having autosave enabled.

    So i’m kinda hopeless right now, been trying stuff for hours now but no luck. If anyone ahs suggestions, let me know, i’m able to test and try all kind of things on my blog.

    ok, this seems to happen when publishing a new post, and also when trying to save it as draft. This both aint working. Below the editor it shows it saved a draft, and it did, but i cant do it myself….

    come on guys, a lot of people have this problem according to a search in the forums, no one a good definitive solution for this?

    Ok i just found out some more details by simply testing

    – the “quickpost” on the wordpress dashboard works and actually posts like normal in IE7
    – Adding a new post in IE7 fails when directly publishing
    – Editing a concept post which was saved before works fine in both IE7 and FF
    – Adding a new post in FF works just fine when directly publishing

    I also noticed the following: When writing a new post in IE7 i see at the bottom of the editor that its saving the post as a concept (and it shows me a date/time when its done, after 1 or 2 seconds)
    When i do exactly the same thing in FF it tries saving it as a concept but no matter how long i wait, it doesnt complete the saving.

    any ideas?

    Ok, because disabling the autosave caused problems for me i tried some more and notice i had to deactivate the ‘post’ script also to avoid getting a javascript error while going from title field to editor.(i have no idea what this script does, but i didnt notice anything wrong after deactivating it…) And cause i didnt like the wordcount anyway i disabled that to:P

    I Got everything working right now by activating this plugin:

    <?php
    /*
    Plugin Name: Your attempt Fix
    Version: 1.0
    Plugin URI: http://www.wordpress.org
    Description: Fixes the very anoying "Your attempt to edit this post" bug in WP7 admin
    Author: Bas
    Author URI:
    */
    function wp_27_adminpost_fix() {
    	wp_deregister_script('autosave');
    	wp_deregister_script('post');
    	wp_deregister_script('word-count');
    }
    add_action( 'wp_print_scripts', 'wp_27_adminpost_fix' );
    ?>

    How to I implement this?? Thanks.

    I’d like this plugin too… does anyone know where I might be able to find this?

    I’m using WordPress 2.8.2 and this morning this problem started occurring. I was adding some plugins to get the WordPress iPhone app to work, but when this started occurring I disabled them. I disabled the RPC publishing altogether and still the problem persists now.

    The plugin mentioned above does indeed suppress the error, however it doesn’t really solve the problem. Autosave is a great feature that many of my posters have come to rely on.

    A true fix would be a solution that keeps the autosave and supresses the error message.

    This problem is a real ghost in the machine. I have a site I use for development and it is exactly the same as the live site. Both sites have identical files and data. Both are on the same server. The only difference is the URL. I was able to get the same problem, however, I deactivated all of my plugins and the problem disappeared. I re-activated the plugins one by one trying to find out which one was causing the problem, and the problem did not reoccur. I tried deactivating and reactivating all of the plugins on the live site and the problem persisted.

    Any suggestions??

    Thanks for the fix lifestyler, I’ll try if i can find the bug in core and fix it, but this solves my problem for now!

    I’ve done this to disable autosave and it solved the problem for me:
    uncomment the line
    wp_enqueue_script('autosave');
    in post-new.php

    Did you mean “comment out”?

    S.K

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Your attempt to edit this post: “abc” has failed !!!’ is closed to new replies.
Skip to toolbar