Support » Fixing WordPress » Your Attempt to Edit Post “” Has Failed Issues

  • I keep having this issue and no matter where I search I cannot find a solution. I have tried the “fix” by turning off the autosave but that created more problems for the site than by keeping the autosave on.

    Is there any support for this or an idea of when WP might fix the issue?

    This is something that just popped up within the last couple of months and it is driving me insane. I’ve read some people who havent had the problem and now starting to think it might be a web server issue?

    I am using a Plesk Windows server. Is it possible this could be the problem?

    I am not sure what the deal is, but I have a local copy of my website on my desktop and posting works fine. All plugins are installed on the local machine and have no issues.

    I did a test post on my live site without any custom fields and the posting worked fine. I did this three more times with one of those times using custom fields and it worked.

    However, all of the tests posts were just text, no coding at all. Could this be an issue now?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator

    One thing that won’t help you is creating multiple threads with the same topic.

    I don’t have this issue so I can’t really comment. But one thing that might help you here is if you can provide provide the version of WordPress, version of PHP, plugins, etc.

    I wouldnt have to create multiple threads if there was some credible answers.

    If you read to the right of the topic discussion you will see I am using WP 2.8. However, I’ve had this issue since I upgraded to 2.7. Just all of a sudden the issue arose.

    I’ve been using the same plugins – Featured Content Gallery, WP Super Cache, Google XML Sitemap, and SimplePie for WP.

    Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator

    I am not sure what the deal is, but I have a local copy of my website on my desktop and posting works fine. All plugins are installed on the local machine and have no issues.

    Local desktop version works, web server version displays the problem occasionally. I’m drawing a blank but something’s different between those two environments. Can you do the following and create a file called phpinfo.php with just this line in it

    <?php phpinfo(); ?>

    Load that file on your browser via both your local desktop version as well your server version. That will give you a dump of your PHP environment for both installagtions.

    Check the major and minor version numbers of your PHP and see if anything in the output leaps out at you.

    Well it appears the versions are different. On my live site I am using PHP 5.2.6 and on the local site it is using PHP 5.2.9.

    Would that be possible to change how things are in my wordpress installs?

    I will try to repoduce the error in my local install.

    No error when testing. Just sent request to server admins to upgrade PHP.


    Any solution for this issue? I’m having the same problem.
    My WordPress version is 2.8.1.


    I’m also having the same issue. I’m using 2.8.5 but this has been happening since upgrading from 2.7

    I’ve searched all over but can’t figure out what’s going on. Any help would be greatly appreciated.



    In both WordPress 2.8.4 and 2.8.5 (we have 3 WP blogs that are affected by this bug), I’ve found that if you do enter the body of the post and not enter a title, you can skirt this bug. After you select “Save Draft” or “Publish”, you can go ahead and enter the title and save it. (My permalinks setting is set to Default.)

    BTW, I’ve also imported the contents of one blog into a brand new WordPress blog (into a fresh MySQL database) but that didn’t work either which leads me to conjecture that something in the contents is triggering this bug.

    I just got this problem.

    I was running my site on my test server, and we wanted to move it to the production server. Got the same problem as listed above

    Mikeo’s issue of not entering the title is the same for me. I can post fine except when I’ve entered a title and the first draft is saved. It doesn’t matter what I’ve typed in the body or categories.

    What happens in my case is that if a first draft is saved and the url is created, i won’t be able to post. The issue is when I click out of the title box, a draft is saved.

    I’ve disabled each of my plugins and mu-plugins, no luck.

    I’m hoping to roll out my small business – WordPress MU is essential to it! I’m holding back though until I know it will be a seamless experience for all, much to my wife’s annoyance.

    PHP 5.2.12
    Wordpress MU 2.91
    Buddypress 1.3 (i disabled this for testing too)

    Does anyone know what might effect this?

    I’ve disabled autosave for a temporary solution, by commenting out the line in /wp-admin/sp-postnes:


    Count me as another person with this problem. I’ve found that it happens on a new post if try to publish first. The workaround I have found is to save it is a draft, close the edit screen, then go back into the draft and publish it.

    I’m another.
    I’m running 2.8.5 and have the same issue. When I try to publish or schedule I get the attempt to edit has failed message.
    I have activated and re-activated the plug-ins, but that hasn’t solved anything.
    One work around I have discovered is to leave the post alone for a few minutes before publishing. I have no idea why, but this sometimes works.
    But this can be a royal pain.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Your Attempt to Edit Post “” Has Failed Issues’ is closed to new replies.