Support » Plugin: IP Geo Block » "You'll be blocked after you log out" notice doesn't disappear

  • Resolved Anton

    (@anton-newpointdeviewcom)


    Hi,

    the message “IP Geo Block: You’ll be blocked after you log out. Please confirm “Matching rule” and “Country code for matching rule” at Validation rule settings. Otherwise select “Block by country (register, lost password)” for “Login form” at Validation target settings.” doesn’t disappear after multiple sittings savins.

    If I switch it off manually, it appears the next time I refresh any admin page

    https://wordpress.org/plugins/ip-geo-block/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi Anton,

    Sorry for my poor and not straightforward description… Unfortunately, currently this plugin doesn’t support multisite, but it works fine in my local PC’s multisite environment.

    I can’t get the meaning of “switch it off”. Do you mean “Deactivate” or “Network Deactivate”?

    The message will apear when:

    1. You select “White list” as “Matching rule” and your country code IS NOT in “Country code for matching rule“.
    2. You select “Black list” as “Matching rule” and your country code IS in “Country code for matching rule“.

    So first of all, please find your coutry code in “Your IP address / Country” and confirm the above selection.

    If I missed something, please give me more details about your situation.

    Thanks.

    Anton

    (@anton-newpointdeviewcom)

    Hey,

    in my English “switch off” means “turn off” / “shut down” 🙂
    See this picture

    And here you can see my settings. Seems to me it has been set correctly

    Anton

    (@anton-newpointdeviewcom)

    Actually I’ve just discovered, that if i put my country in the white list, the notice disappear.
    But if I need to block admin access from my country, but open it only to several IP addresses, will this notice be appearing all the time ?

    Plugin Author tokkonopapa

    (@tokkonopapa)

    OK, I got it.

    Unfortunately, currently the admin notice can’t be disappeared with your situation.

    My recommendation is:
    1. Put your country code into “Country code for matching rule“.
    2. Put the following .htaccess into your wp-admin directory (if your server is apache).

    order deny,allow
    allow from x.x.x.x
    allow from y.y.y.y/z
    deny from all
    <FilesMatch "admin-(ajax|post).php$">
        Satisfy Any
        Order allow,deny
        Allow from all
        Deny from none
    </FilesMatch>

    The sample in codex (https://codex.wordpress.org/Brute_Force_Attacks#Limit_Access_to_wp-admin_by_IP) can allow to access admin area only from specific IPs. But you need to allow ajax for others.

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi Anton,

    I’ll fixed this issue in the next release.

    Currently (under 2.2.3.1) only the country code of your IP address is validated to make the admin notice. But definitely it should be fully validated.

    Thanks for your openning this issue!

    Anton

    (@anton-newpointdeviewcom)

    Hi,

    so does it mean I don’t need to modify my .htaccess file, since you want to fix the issue in the next release?

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi Anton,

    Yes, if you have a kind patience. I’ll release the new version within several days. But…

    If you can identify the range of your IPs and prefer to reduce your server’s load, I think the solution by .htaccess is the best.

    It’s your choice.

    Thanks.

    Anton

    (@anton-newpointdeviewcom)

    All right.
    Thank you

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘"You'll be blocked after you log out" notice doesn't disappear’ is closed to new replies.