Support » Plugin: WooCommerce Payments » “You specified “never” for fields.billing_details.address.line2″ error

  • Resolved kevbot1

    (@kevbot1)


    Hi WP community,

    I am using WooCommerce and have been prompted by the system to update existing plugins to WooCommerce Payments. A big mistake and many headaches so far, as well as missed sales. Needless to say, I’m pretty annoyed at how this plugin has been rolled out and its lack of production readiness and consequent stability. Not cool.

    The latest update to the plugin fixed the critical errors that I was receiving on unrelated, non-WooCommerce pages that sent me on a wild goose chase. It was the only plugin I updated as I hunted down the culprit, which inadvertently resolved the issue.

    But this current issue (which will most likely see the plugin deleted until it’s stable) is producing this error:

    You specified "never" for fields.billing_details.address.line2 when creating the payment Element, but did not pass confirmParams.payment_method_data.billing_details.address.line2 when calling stripe.confirmPayment or stripe.confirmSetup. If you opt out of collecting data via the payment Element using the fields option, the data must be passed at confirm-time.

    I can only find the topic listed by Will Brubaker in Git but can’t find any more assistance on this matter.

    This issue-plagued plugin is not good for business. It’s without question one of the most important components of an e-comm site that simply MUST be stable. I appreciate a response from the Automattic or WooCommerce team with a solid fix.

    Otherwise, suggested alternative plugins that support Paypal Pay in 4 and Credit Cards without being prompted to “upgrade” to this currently problematic plugin again would be really appreciated.

    Thank you.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Marcin

    (@robobot3000)

    Hi @kevbot1!

    Thank you for reporting the error!

    Do you have any plugins that allow you to edit the checkout fields installed and hide the input field for the second line of address? If so, showing the second address line again at your checkout should help with the issue.

    Alternatively, if you’re not using the Giropay/Sofort payment methods, you can switch back to the old WooCommerce Payments checkout element by following the steps here: https://docs.woocommerce.com/document/payments/additional-payment-methods/#section-7

    This is not an intended experience and I have raised this issue with our developers who should look into it soon.

    Hope this helps!

    Plugin Support Sol J. a11n

    (@solstudioim)

    We haven’t heard back from you in a while, so I’m going to mark this as resolved – I trust that what Marcin said points you in the right direction, but if you have more questions, let us know.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.