Support » Plugin: Twitter Widget Pro » "You need to authorize your Twitter accounts"

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Aaron D. Campbell

    (@aaroncampbell)

    Please read the thread titled “Instructions for Non-Tech ppl for Twitter Authorization Issue” – http://wordpress.org/support/topic/instructions-for-non-tech-ppl-for-twitter-authorization-issue

    Could not recognize the response from Twitter. I receive this message after I have setup the plugin. I have setup my Consumer key and my Consumer secret. What do I do to authorize my Twitter account.

    Plugin Author Aaron D. Campbell

    (@aaroncampbell)

    Make sure that you added a valid callback URL when you created your Twitter app. Just use the URL for your site.

    Hi Aaron,

    It’s not accepting my URL in this process. I am using our website address, but it just won’t take it – any advice?

    Dee

    Maybe I am not typing it correctly?

    Plugin Author Aaron D. Campbell

    (@aaroncampbell)

    Unfortunately, that part of the process is all on Twitter and I have nothing to do with it. Just make sure there is a valid URL there. Even if you have to use google.com it should work.

    That URL is never actually used, but Twitter creates two different types of Twitter Apps based on whether you have a valid callback URL or not (I know this isn’t clear…but again, that’s all Twitter)

    Hi there, i still can’t connect to the twitter widget and i don’t get it why. I created a app key en consumer key etc.

    Filled those things in, authorized my app with the account. Now the account I authorized doesn’t show up on the page and still it is asking me to authorize my account. This was this morning about 3 hours ago. Still same.

    The account I am trying to connect is a business account, this didn’t work so I tried a normal account this also doesn’t work. So I am kinda stuck and don’t know any more what to do.

    We are ussing wordpress 3.3.2. and thet latest plugin from twitter widget pro. 2.5.4.

    Would be great if somebody can help me out.

    Exact same issue. Anyone solved it?

    Thanks

    Hi !

    This is a quick and dirty fix, but it’s work !!!

    In the file
    /twitter-widget-pro/lib/wp-twitter.php

    In the line 121 add belong to

    $decoded_response = wp_parse_args( $resp[‘body’] );

    this fix

    // fix : wp_parse_args not working with the $resp[‘body’]
    if(!is_array($decoded_response) && !is_object($decoded_response)){
    $_url = explode(‘&’,$decoded_response);
    $decoded_response=array();
    foreach($_url as $_u){
    $__u = explode(‘=’,$_u);
    $decoded_response[$__u[0]]=$__u[1];
    }
    }

    regards

    alas, i’ve had the above problem ever since i updated to v2.5.4. that was 4june just before the api 1.1

    so i deactivated two weeks ago and now just reactivated and same problem. i would really like to hear from someone who says it works right out of the box instead of dirty fix.

    i have four authorized twitter applications and can’t grab one in the drop menu or add twitter username.

    Hello,

    Try to change the Access level to ‘Read and write’ and fill the Callback URL: form with your website URL (http://yoursite.com)

    Hope it works for you guys too.

    Regards

    thanx mariogarcia.ar, you saved my day!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘"You need to authorize your Twitter accounts"’ is closed to new replies.