Support » Plugin: Widget Importer & Exporter » You must upload a .wie file generated by this plugin.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Steven Gliebe

    (@stevengliebe)

    Please try uploading the same .wie file with all other plugins inactive and tell me if it works or if you see the same “must upload a .wie” message.

    alx359

    (@alx359)

    Yes, already did. It works with all plugins active but MLA disabled (have MLA-based widgets being used).

    The MLA developer is very supportive. Hope you may find a fix soon enough.

    Thank you.

    Plugin Author Steven Gliebe

    (@stevengliebe)

    Thanks for trying that.

    Let’s try generating an export file without MLA widgets to determine if the problem is with the MLA plugin’s widget settings or if it’s a problem with MLA being active.

    1. Temporarily remove the MLA widgets from your site (you can drag them into the Inactive area at the bottom-left in Appearance > Widgets).

    2. Export the widgets with WIE.

    3. Try importing the .wie file (having no MLA widgets) while the MLA plugin is still active.

    Sometimes a plugin will register widgets that do something special with the settings / data that WIE doesn’t anticipate. That may or may not be the case here but this test should confirm or rule that out.

    Please also upload the .wie file somewhere and I’ll take a look at its contents.

    alx359

    (@alx359)

    Followed the instructions, but the import with the MLA widgets disabled and MLA plugin active was unsuccessful once again. When the MLA plugin is inactive the newly made .wie file imports fine.

    For both .wie files, please refer here.

    Please let me know if I could assist further.

    Thank you.

    Plugin Author Steven Gliebe

    (@stevengliebe)

    It seems the issue is not with MLA interfering with the generation of the .wie file but rather something happening when MLA is active that is preventing the import of any .wie.

    This error can happen if the file is empty or if it does not have a .wie extension, but neither is the case here. It can also happen if your WordPress configuration does not allow for .wie files to be uploaded. The plugin will enable this by default but it’s possible for another plugin to interfere and I suspect that is what is happening. A couple things to check:

    1. If you’re on multisite, in your multisite network settings, try adding ‘wie’ to “Upload file types”. This should not be necessary but it’s worth a shot in case there is something usual going on.

    2. You can also try forcing a re-add of the type with a plugin like this: https://wordpress.org/plugins/wp-add-mime-types/. The wie type is registered as application/json.

    3. Ask MLA if they are aware of any situations in which their plugin can prevent or override other plugin from adding mime types. Or, check to see if there is a setting in MLA for mime types.

    alx359

    (@alx359)

    1. No multisite
    2. Installed wp-add-mime-types and added wie = application/json, as it wasn’t already there. No difference.
    3. In MLA, there’s indeed a suggestive option checked in Views > Enable View and Post MIME Type Support. Unchecked this but made no difference, unfortunately.

    MLA is quite complex, so it seems we’d have to wait for the MLA developer to chip in the OP reference.

    Thank you.

    alx359

    (@alx359)

    By enabling the mime-type plugin troubleshooting mode (it deactivates all other plugins), just noticed that the newly added wie mime type line should be included marked in red along with the other registrations. Getting out of troubleshooting that red line inclusion isn’t there.

    Also activating Widget Importer & Exporter during troubleshooting mode the wie mime registration appears automatically along with the others (not in red).

    So it seems that something is indeed masking the proper wie registration.

    @stevengliebe – Thanks for all of the work you’ve put in to working with @alx359 on this issue. I have posted my response to the topic he raised in the Media Library Assistant support forum:

    Widget Importer & Exporter plugin conflict

    alx359

    (@alx359)

    Thanks so much, David and Steven! Both suggested MLA solutions work perfectly, and the Widget Importer & Exporter works fine now.

    Plugin Author Steven Gliebe

    (@stevengliebe)

    That is good to hear!

    hello, i dont have MLA pluggin and the same is just happening to me, how can i fix it? it keeps saying “You must upload a .wie file generated by this plugin.” and i’ve tried all the historical versions i’ve been saving

    thanks

    UPDATE: I saw another topic resolving this, i’m going there 🙂

    • This reply was modified 5 months, 1 week ago by  Patricil.
    Plugin Author Steven Gliebe

    (@stevengliebe)

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.