Support » Plugin: Widget Importer & Exporter » You must upload a .wie file generated by this plugin.

  • Resolved ecollegey

    (@ecollegey)


    I have a similar problem as some of the other forums. I’m trying to import a file that definitely ends with a .wie, but I keep getting the message “You must upload a .wie file generated by this plugin.”. I tried deactivating all of my other plugins and then trying to import but that didn’t work. The .wie file is supposed to be widgets from a theme. Any suggestions? Thanks!

Viewing 15 replies - 1 through 15 (of 30 total)
  • Yes, I am having the same exact problem.

    I have the same problem, even with all other plugins deactivated. And, if I export the existing widgets and try to import them again I get the same message. I am choosing the correct file and it has a .wie extension. Any suggestions on what else to try?

    Plugin Author Steven Gliebe

    (@stevengliebe)

    It’s interesting that you are all experiencing the same issue at around the same time. Please tell me:

    1. What version of the plugin you are using
    2. What version of WordPress you are using
    3. What version of PHP is your host using (this is helpful: https://rup.wordpress.org/plugins-wp/display-php-version/)

    You can also send me a copy of your .wie file using my email address listed at http://stevengliebe.com

    The problem is usually due to a plugin interfering with mime types. Widget Importer & Exporter registers .wie but another plugin can undo that. Here is information on that: https://wordpress.org/support/topic/you-must-upload-a-wie-file-generated-by-this-plugin-1/#post-7348636

    1. Plugin version 1.3.2 – downloaded & installed today
    2. WordPress 4.7.1 – installed today on a new domain (although in an ‘AddOn’ site)
    3. PHP – likely to be latest one as I’m making a new site on SiteGround

    Yes I found that post about interference but couldn’t see anything on my site that was likely to be causing it. Having said that I’m relatively new to WordPress (although from a very solid programming background).

    Anything else I can try or do to help?

    Plugin Author Steven Gliebe

    (@stevengliebe)

    I can confirm this issue myself. It happens on WordPress 4.7.1 which was released yesterday. It seems a bug or breaking change was introduced in that version:

    https://core.trac.wordpress.org/ticket/39550

    Can each of you confirm you are using 4.7.1?

    I’m keeping an eye on this ticket. Hopefully it will be deemed important enough for a quick fix. Otherwise I’ll look into releasing an update with some kind of workaround.

    Thanks Steven.
    Hmmm, I was wondering if it could be the latest update. Bit of a nuisance as it stops me in my tracks. Do you know how quickly things like this are usually fixed?

    i can confirm the same problem with wordpress’s version 4.7.1

    Same problem, using WP 4.7.1, and I’m fairly certain that’s the culprit as I maintain several sites, and the only ones with the issue are the ones using 4.7.1.

    We are experiencing this same trouble as well. So far we’ve had it on 2 sites, all on 4.7.1. We are a theme developer and recommend this plugin for all our themes so I anticipate seeing many more. We’ve ruled out another plugin conflict as well, so it looks like it’s specifically something in the 4.7.1 update.

    Lauren

    Plugin Author Steven Gliebe

    (@stevengliebe)

    Thanks everybody for the info. A workaround would be to temporarily add this to wp-config.php:

    define('ALLOW_UNFILTERED_UPLOADS', true);

    And temporarily remove or comment out this block in wp-content/plugins/widget-importer-exporter/includes/import.php:

    		// Check file type
    		// This will also fire if no file uploaded
    		$wp_filetype = wp_check_filetype_and_ext( $uploaded_file['tmp_name'], $uploaded_file['name'], false );
    		if ( 'wie' != $wp_filetype['ext'] && ! wp_match_mime_types( 'wie', $wp_filetype['type'] ) ) {
    			wp_die(
    				wp_kses(
    					__( 'You must upload a <b>.wie</b> file generated by this plugin.', 'widget-importer-exporter' ),
    					array(
    						'b' => array()
    					)
    				),
    				'',
    				array( 'back_link' => true )
    			);
    		}

    You’ll want to undo these changes after you import since it’s possible they could create a security issue. Better safe than sorry.

    I’ll decide tomorrow if I’ll change the way the plugin works to deal with this or if I’ll wait for an update to WordPress. If it’s deemed urgent in core then an update might be just a few days away but it could also be weeks or months. I’ll check the trac ticket tomorrow to see if I can gauge that (assuming I’m right about that being the issue).

    I’m sure there were be more threads open on the .org forums as this seems to affect uploads of various types in general. And I know a lot of theme shops ship WIE files for their sample content. We’ll get this resolved one way or another without too much delay. 🙂

    getting the same error here too man, started yesterday, tried again today – doesn’t seem to be recognizing the file. it’s not vital, but it does make life a little easier! 🙂

    Plugin Author Steven Gliebe

    (@stevengliebe)

    Yeah, didn’t expect a minor WP update to affect this. Will get it solved one way or another. Just waiting to see how that thread on trac evolves. I’m sure a lot of theme shops are getting questions about this right now. 😉

    Plugin Author Steven Gliebe

    (@stevengliebe)

    Okay, this will be fixed in WordPress 4.7.2. No ETA but this plugin will disable the particular change introduced in 4.7.1 that causes the problem. You can import widgets fine after activating this plugin. This is the best way to deal with it for now.

    https://wordpress.org/plugins/disable-real-mime-check/

    This workaround is preferred to the one I posted above.

    • This reply was modified 3 years, 6 months ago by Steven Gliebe.

    Thank you so much! this “disable real mime check” plugin got the job done!

    Thanks very much Steven, the plugin has enabled me to continue working on my site!

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘You must upload a .wie file generated by this plugin.’ is closed to new replies.