Support » Plugin: Colissimo Delivery Integration » You must select a pickup location. Please try again.

  • Resolved lesbelleshistoires

    (@lesbelleshistoires)


    Hello Harasse
    When the customer has chosen a pickup location (Point Relais) and wants to proceed to the payment, he gets a warning : “You must select a pickup location. Please try again.”
    The choosed location does not seen to be taken into account. How can I resolve that please ?

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Halyra

    (@harasse)

    Bonjour,

    Votre problème se produit-il uniquement sur certains navigateur ?
    Faites un essai sans les autres plugins, en conservant uniquement Woocommerce et CDI, pour voir s’il n’y a pas un conflit avec un autre plugin.

    lesbelleshistoires

    (@lesbelleshistoires)

    Bonjour, Effectivement le souci n’apparaît pas avec Firefox (mais avec Chrome).
    Et banco, c’est effectivement le plugin WPS Hide Login qui provoque ce message. Je vais trouver une alternative. Merci ! Sujet clôt.

    lesbelleshistoires

    (@lesbelleshistoires)

    Bonjour, Juste pour info, il y a aussi incompatibilité entre CDI et iQ Block Country (qui était paramétré de façon à bloquer RU, UA et CN uniquement).

    lesbelleshistoires

    (@lesbelleshistoires)

    J’ai désactivé un bon nombre de plugins mais rien n’y fait : le fonctionnement est très aléatoire : ça passe une fois puis la seconde j’obtiens le message suivant “Vous devez choisir un point de retrait. Essayez de nouveau SVP.”
    J’ai bien sûr supprimé le cache et désactivé le plugin de cache; le debug CDI est activé ; je ne vois rien d’anormal.
    La version WC est 3.2.1 et je vois dans WC>Etat qu’il est indiqué que le plugin CDI en 2.0.6 est indiqué “Not tested with the active version of WooCommerce”. Est-ce que ceci peut expliquer cela ?

    lesbelleshistoires

    (@lesbelleshistoires)

    Il semble s’avérer que c’est effectivement un problème de plugin. Le “coupable” serait WPML Translation Management qui est nécessaire pour faire fonctionner WooCommerce Multilingual. Et WC Multilingual est très utile. Le sujet est clôt mais s’il est possible de prendre en considération WPML Tr. Management dans une future version, ce serait formidable.
    Et encore merci pour votre persévérance dans le support de CDI.

    Plugin Author Halyra

    (@harasse)

    Bonjour,

    Une correction dans la version 2.0.3 a déjà été faite pour rendre CDI moins sensible à WPML. Mais WPML semble utiliser un cache interne qui peut créer ce problème dans la page checkout.
    Le seul remède pour certains sites semble être de changer l’ordre d’activation des plugins (CDI d’abord puis WPML ou inversement).

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘You must select a pickup location. Please try again.’ is closed to new replies.