Support » Plugin: BridgeDD » You have to work (a bit) to make it work ;-)

  • manutoo

    (@manutoo)


    So as specified in the installation instructions, I had to disable eAccelator (it seems there’s no universal way to do this, so it depends of your own setup), else nothing was happening.
    This pluging settings force you to disable either the registration of users in WP or PhpBB3, and it removes the related “register” links, but both login pages are still active, so it means one of them doesn’t have any “register” link and thus become puzzling for new users. I had to hack my way in WP to make all logins sent to PhpBB3.
    Hint: PhpBB3 supports “redirect” parameter on its login page, so you can add that in your theme functions.php file :

    add_filter( 'login_url', 'custom_login_url', 10, 2 );
    function custom_login_url( $login_url, $redirect ) {
        $new_login_url = '<YourForumURL>/ucp.php?mode=login&redirect='.$redirect;
        return $new_login_url;
    }

    Plus it’s required to manually edit bridgedd_config.php to make the ugly “do you want to integrate your account into WP” screen disappear.

    Except that, it works nicely, and doesn’t take any extra CPU resource, unlike another bridge I tried that was hacking PhpBB3’s common.php file to load WP login stuff inside the Forum.

  • The topic ‘You have to work (a bit) to make it work ;-)’ is closed to new replies.