Support » Plugin: Wordfence Security - Firewall & Malware Scan » You have an error in your SQL syntax…

  • Resolved danjde

    (@danjde)


    Hi Support!
    I’m using Wordefence free version 7.1.12 and WP 4.9.8.
    Looking into Apache error logs I’ve found many of these warning:

    
    [Tue Sep 18 19:43:52.553516 2018] [:error] [pid 17508] [client 146.241.90.187:8718] WordPress errore sul database You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'update-plugins wf-menu-badge wf-notification-count-container' title='1'><span cl' at line 1 per la query SELECT slug FROM wp_terms WHERE name='Wordfence <span class='update-plugins wf-menu-badge wf-notification-count-container' title='1'><span class='update-count wf-notification-count-value'>1</span></span>' fatta da require_once('wp-admin/admin.php'), require('wp-admin/menu.php'), require_once('wp-admin/includes/menu.php'), do_action('admin_menu'), WP_Hook->do_action, WP_Hook->apply_filters, call_user_func_array, wordfence::admin_menus, add_menu_page, sanitize_title, apply_filters('sanitize_title'), WP_Hook->apply_filters, call_user_func_array, EightDegree_sanitize_term_translate, referer: https://www.mysite.net/wp-admin/edit.php

    These warnings occur by moving within the administrative side as administrator.
    Now I’ve installed (and active) these plugins:

    Adminimize
    Coming Soon Page & Maintenance Mode by SeedProd
    Contact Form 7
    Eight Degree Custom Posts
    Eight Degree Shortcodes
    Re-Add Text Justify Button
    Revolution Slider
    Scroll Magic
    Simple Custom Post Order
    SVG Support
    User Role Editor
    WooCommerce
    Wordfence Security
    WPBakery Page Builder

    I’ve open a post on wordpress.org forum where they suggest me to write to Wordfence support for this issue.

    Many many thanks!

    Davide

Viewing 9 replies - 1 through 9 (of 9 total)
  • I’ve just try to disable (and re-enable then) all plugins.
    Only disabling Wordfence the MySQL error warning log stop.
    I’m using MySQL 5.5.59 and Apache 2.4.10.

    Thanks again!

    Hi @danjde

    This is most probably a theme or a plugin causing this issue, I suggest disabling all other installed plugins and reverting back to the default WordPress theme, then re-enabling the plugins/theme one by one to find out the culprit.

    A very good way to do that on live website is to use “Health Check” plugin, as it has its own “Troubleshooting guide” that works only on the logged-in session, so you don’t worry about other users visiting your site.

    Thanks.

    Very well!
    I will investigate,
    thanks for your help very appreciated 😉

    Davide

    Hi @danjde,
    Since we haven’t heard from you for a while I’m going to go ahead and resolve this thread. You are welcome to create a new one at any time!

    No I’ve not solved it! The question depend conflict between the template (commercial) and Wordfence security plugin.
    The developer is disappeared and the problem remains! 🙂

    Thanks anyway!

    Davide

    Hi @danjde,
    Since this isn’t something we’re seeing on other sites and it seems to be related to a theme which is no longer being actively maintained by it’s developers I’m afraid there isn’t much we can do. I would recommend you try to find a replacement for your theme.

    I would recommend you try to find a replacement for your theme

    Eh, it’s not so easy 🙂
    The “positive” side of this problem is that it presents itself only by operating from the backend..

    • This reply was modified 1 year, 3 months ago by danjde.

    Hi @danjde,
    I understand it’s not easy but to keep your site safe it’s important to only use software that is actively maintained. The only alternative would be to hire a developer who can look in to the EightDegree_sanitize_term_translate function in your theme and see if they can fix it.

    Wish you the best of luck with your site for now!

    The only alternative would be to hire a developer who can look in to the EightDegree_sanitize_term_translate function in your theme and see if they can fix it

    Yes, this is what I will do!

    Thanks again @wfasa!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘You have an error in your SQL syntax…’ is closed to new replies.