Support » Fixing WordPress » “You Don’t Have Permission To Do That” – Can’t delete posts/categories

  • Resolved ecetim


    I signed up for a new hosting provider and used Fantastico to install WP 2.0.6. I then followed the upgrade instructions to move up to 2.1.

    If I try to delete a post under the “Manage” tab, it says “You do not have permission to do that.” Same if I try to add a category.

    I am the only user setup on this blog and I am an Administrator.

    I have changed the CHMOD permissions to allow anyone to write/read/execute my entire wp folder.

    Other people ran into this problem in the past, but none of the tips I found have helped. Here are the links I found relating to this:

Viewing 15 replies - 1 through 15 (of 54 total)
  • ecetim


    It is related to Javascript – if I disable JavaScript in FF it works. Experimenting further…



    OK I found it. Go to Tools–>Options–>Content. Select “Advanced” and make sure “Change status bar text is checked.” Voila, you should be good to go!

    This is in FF



    Nevermind….for some reason that doesn’t work anymore. Disabling Javascript lets you add/delete stuff, but of course causes other problems. In the meantime I will disable Javascript when I need to modify, otherwise leave it on.

    Any help?



    I would suggest you install Firebug and see if anything shows up in the console. It might help narrow the problem area.



    I should have said, Firebug is a Firefox extension:



    wow I think I found it….

    it was a plugin!!!!!!

    That thing “You dont have permission to do that” started happening yesterday and I was like what the?
    so I spent all of today looking through forums and everyone kept saying stuff about Javascript and that sorta thing…

    so a minute ago I thought… well it did start happening after I activated that plugin.

    DO you guys use “Kahn’s Instant Notepad” – for the record I thought that was a cool plugin, but I’m sorry it’s interefering with the ability to edit stuff!

    all you need to do is deactivate that plugin and you’re fine!

    either someone fix that plugin or get buggy challenged.



    no i dont have that plugin

    im so desperate i tried all the tricks to no success

    the only trick that worked is disabling javascript in firefox

    but as you all know i cant just disable it because some if not most of wordpress core files need javascript

    I got myself a firebug but i cant locate where the error is, though it appears to be in the .js files in wp-includes directory

    until this is fixed by the admins/developers, am so terribly helpless!



    If you have a public link to your installation I’ll take a look.



    hi jkeyes, what do you mean?



    Sorry forgot this it was a wp-admin issue you were having.

    If you want to set up a temporary account and email me details you can, I understand the trust issues involved here so it’s no problem if you don’t want to.



    It seems some code in my plugins clashes with certain WP Javascript functions. I have fixed the problem, so if you use either KCA, KIN or KQF, please go to and download the latest versions.



    I’m having the same issue on my blog as well, the funny thing is that it has radomly started…no more adding/delete of Categories..just “You do not have permission”

    What I’ve tried:

    Turning off ALL plugins
    Switching to default theme
    Trying Opera/Firefox/IE6 to create a category
    Doing that above mentioned firefox/status bar trick
    Made sure I’m the admin account on WP

    The only thing that worked is disable JavaScript in FF and make the category.



    Ditto Techz and add Safari to the browser list



    It seems some code in my plugins clashes with certain WP Javascript functions.

    in my case i am certain i dont have any plugin that clashes because the problem is prevalent in a fresh installed wordpress

    Honestly this is ridiculous, when will there be a fix?

Viewing 15 replies - 1 through 15 (of 54 total)
  • The topic ‘“You Don’t Have Permission To Do That” – Can’t delete posts/categories’ is closed to new replies.