You dont have permission to do that. (11 posts)

  1. Badams
    Posted 10 years ago #

    Im not sure whats causing the problem either fantastico or wordpress, so i'll explain my situation.

    Ok i used fantastico to install wordpress on my server and it worked great, everything was going great and i was starting to get some traffic.

    then a friend asked if i could setup a wordpress install for them on my server, so i went to do so and somehow clicked remove (which removed my old installation) which was ok since i had made a backup so i installed wordpress again (all went well) and went into the admin but now for some reason i dont have permission to do anything, for instance delete the initial post that wordpress comewith as an example "hello world" when i try to delete it it simply says "You do not have permission to do that."

    i've tried so many things deleting the subdomain and creating it again, differnt chmods (not that it would help), unisntalling and re-installing wordpress 4-5 times

    this is all i can think to do, in the mean while i've setup a simple redirect from my old subdomain (http://blog.dontfollowme.net) to my new subdomain

    though i would really like get it back to the original URL as that one has other sites linking to it and i liked the old url better :P,
    if anyone has any idea why this is happening i would be so greatfull for your help

  2. Mark (podz)
    Support Maven
    Posted 10 years ago #

    If you are using Firefox, what extensions are you using?

  3. Badams
    Posted 10 years ago #

    im using these,

    • IE tab
    • web developer 1.0.2
    • A9 toolbar
    • del.icio.us 1.1

    also, as mentioned above i am still able to install wordpress on my server it only if i use the blog subdomain that it starts acting weird..

  4. katesgasis
    Posted 10 years ago #

    What did you use to backup your db and how did you install your backup? Because if you use fantastico to install wp the 2nd time, it created a new database with new values in the usermeta able. Any new user that is entered into that table will have a default permission of subscriber.

  5. Badams
    Posted 10 years ago #

    Well the thing is this happens regardless if i restore the csv or if i just stick with the db wordpress just created

    and i used the plugin that comes with wordpress 2.0.3 for backing up. and just restored it using phpmyadmin and modifying wp-config.php

  6. Badams
    Posted 10 years ago #


  7. yosemite
    Posted 10 years ago #

    Might want to check this out:

  8. Badams
    Posted 10 years ago #

    thanks for the link, tho i am still the administator (i did check following that tutorial(just incase)) . i should have the rights to delete posts, but i dont i can delete comments but thats about it...

    does nobody have any idea why this is happening?

  9. moshu
    Posted 10 years ago #

    It happened something similar to me on a testblog today: while I was logged in, I opened another tab and by mistake logged in as a low level user (contributor). The Dashboard still showed me as "hello, admin" but when I wanted to edit anything I got the "You don't have permission..." msg. It took me a while to realize it was the last coookie (for the level 1 user) that was recognized by WP.
    I am not saying the same happened to you - just sharing this strange experience, hoping somebody might find it useful.

  10. Badams
    Posted 10 years ago #

    interesting, if only my situation was that simple. i wish someone would tell me howto fix this...

  11. ThomasSchulz
    Posted 9 years ago #

    I think this thread should be merged into:


    Seems like many people, myself included, are experiencing this problem.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.