Support » Fixing WordPress » You don’t have permission to access /wp-admin/post.php on this server

  • Resolved ghostfreak


    I’ve been adding posts fine and without hassle ever since I installed WordPress not long ago – but now when I hit the ‘Publish’ button I get a 403 page with the text ‘You don’t have permission to access /wp-admin/post.php on this server.’

    Any ideas?

    I am defiently an administrator (the only one).

Viewing 11 replies - 1 through 11 (of 11 total)
  • This post makes reference to having one post in the install that had some weird code in it that caused this error and deleting that post fixed the problem. Maybe that is the case?

    As well, this post has a suggestion on fixing it with a .htaccess fix. Might be another one to look at.

    This one has something about mod_security on the server being the culprit for not being to add a post. Did you recently upgrade your server security?

    I found most of these through this search and didn’t go through all of them.

    Hope you figure this one out!


    Hmmmm…it seems to work with very little text in the post (eg. hello), I have been pasting in about 8 lines – then I get the 404 message. Although I’ve been adding a URL link to a piece of text as well.

    Any more thoughts?

    Out of curiousity, you said “pasting”. What program are you pasting out of? If you paste into a text program and then copy that text and paste it into your editor does it work? That way, it makes sure any formatting out of the program you are pasting from is gone. Just a thought!


    I am getting about the same thing, You don’t have permission to access /wp-admin/options.php on this server.

    I have reinstlled 3 times and the same thing getting ready to try MovableType

    I paste into Notepad and paste back and it still brings up the same error.

    Handy? Moshu? Samboll? One of the smart people might know as I am out of ideas and searches! Sorry.


    I’ve been trying to paste the first three paragraphs from this page:

    Do you think any of the words would be alerting the mod_security function?

    I contacted my host and they told me it was a problem with the mod_security module. There was some difficulties posting that link I pasted above – so I just went to tinyurl and shortened it down.

    Thanks to all the replies!

    I had this happening out of the blue. My ISP forced a password change for the site, and i think that had something to do with my problem. i went back and restored an older copy of my .htaccess file and it now works fine. I had to verify all my security site wide, like password protected folders, ETC. Hopefully this helps.

    With me, the following phrase gave me the infamous 403 error:

    Once the Hardware Update Wizard appears, choose the option Install from a list or specific location (Advanced) and click next.

    Maybe the CIA is spying on us and thought “specific location” was a security threat and censored me 😉

    Seriously… Sarcam’s apart, what kind of silly error is that that is triggered by keywords?!? Does anyone knows?

    I was having trouble editing posts with code mode. I could create and edit posts with the Visual Editor, but as soon as I made changes in the Code Editor I got “You don’t have permission to access /wp-admin/page.php on this server” once submitted.

    That just didn’t make any sense to me, but the .htaccess info referenced above solved the problem! Thanks guys.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘You don’t have permission to access /wp-admin/post.php on this server’ is closed to new replies.