Support » Plugin: Memphis Documents Library » You don’t have permission to access this resource

  • Resolved profscooter

    (@profscooter)


    Hi all,

    For some time on this site, search results (provided by Search WP) provide links to relevant documents (PDFs), but when clicking on them, there is a permissions error. People then have to remember the title of the document and go and look for it in the documents library instead of clicking the search result (example link attached). I’ve tried various file permissions on the server and nothing seems to have any effect. Any ideas?

    Martin

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author bhaldie

    (@bhaldie)

    mdocs protects this folder so referring files in the folder will create this message. There are a couple of things you can do:

    1. Use the share link for each file. If you click on a file a dropdown menu will appear click on the Share link and use one of the two links there.

    2. Head to the mdocs Options > Settings > .htaccess File Editor and remove all text inside the text box. Be careful with this, removing this text will disable all mDocs privacy options, all files will be completely accessible to everyone.

    The first option sounds better, but the link that appears on the search results page is the one produced by Search WP. Any idea how I get it to output a link that works when clicking on it outside of docs?

    Plugin Author bhaldie

    (@bhaldie)

    Sorry, I don’t know Search WP so I can’t help you there.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.