Support » Fixing WordPress » You don’t have permission to access /blog/ on this server

  • OK, the story so far.

    I had all sorts of problems accessing WordPress, but this was solved by you kind folks here on the installation pages and WordPress has been running fine for the last couple of days.

    However, today, for no apparent reason, it’s stopped dead, with the message in the title.

    Everything I’ve researched so far, suggests there is no index.php file; but there is.

    If I place a plain index.htm file in the blog folder, I can access the file just fine, so clearly,

    a) my browser is looking in the right palce, and;

    b) it goes deeper than a missing index.php.

    Whether I try and access the blog or the login page, I get the same “You don’t have permission” message.

    The only changes that have been made are as follows;

    Last night, I stopped the DNS server, as I thought I didn’t need it running. This has had no effect on my Apache2 server, with my regular web pages being served without errors. I’ve switched it back on this morning, just in case it affected WordPress, but it’s made no difference to the result.

    Reading the installation page, one common error noted, was a missing ?> end tag to the config.php file. I added this, but again, I’ve still got this problem.

    I’ve also added a theme, but don’t know how to restore back to the default, without access to the WordPress control panel. However, it should be noted, that theme has been running for the past two days also, without any problems.

    I’ve checked as best I can phpMyAdmin for database errors, but I’m no expert. However, as far as I can see, it all seems to be up and running.

    Once again, any help would be most appreciated.

Viewing 8 replies - 1 through 8 (of 8 total)
  • I’d be most grateful for any help on this please.

    OK, I’ve just done a complete reinstall, with a clean database, with exactly the same result.

    Completely locked out of WordPress; what on earth can it be?


    Hello, LastChip

    I have the same problem at my first installation of wordpress.

    My message is: You don’t have permission to access /blog/ on this server

    Did you find a solution!

    Thank you!

    This link solved my problem…

    Problem solved:
    <Directory “/your/virtualhost/docroot/with/noslash”>
    Options All ExecCGI FollowSymLinks Includes Indexes
    Allow from All
    Order Allow,Deny
    AllowOverride All Options

    <VirtualHost *:80>
    Options All ExecCGI FollowSymLinks Indexes
    DirectoryIndex index.php index.html index.hml index.phtml index.shtml
    DocumentRoot “/your/virtualhost/docroot/with/noslash”

    I have tried to add the code from LeoPote to my .htaccess but still not work 🙁 . Did it help for LastChip?

    I had a similar problem and the fix was easier than described above. I simply deleted the .htaccess file and let WordPress rebuild a new one.


Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘You don’t have permission to access /blog/ on this server’ is closed to new replies.