Support » Fixing WordPress » "You don't have enough permissions" error in only some menu items

  • Hi,

    I have a very strange error in my wordpress wich suddenly appeared (well, i didn’t noticed wich change was the cause) and i’ve couldn’t guess wich is the solution.

    See, in my blog I have more or less 30 active plugins, when I access to the “advanced options” in some of them, i get the error “You do not have sufficient permissions to access this page”

    but it’s strange because I get them only in few setup pages…

    to be more exactly, in those plugin that create an extra menu below “Settings”, like TweetMeme and WP-Polls

    For example in TweetMeme that has 2 sub-menus, I can enter to the first option and make everything, but when I try to enter to the second one, I end up getting the error message and I can’t do anything.
    In WP-Polls that has 5 sub-menus, I can enter to the first, but I get the error in the other 4 sub-menus.

    Up to now, I’ve installed another blog with the same plugins, and it doesn’t get that error.
    I’ve tried disabling all the plugins, one plugin at a time, but no matter which of them I disable, the error is still there.
    I’ve re-updated the blog to 3.0.1
    Change the database to an older backup
    Googled a lot

    but none of that has functioned

    Could someone help me? Do someone know what could be going wrong with the blog or where should I look for a solution?

    Thank you, all help will be greatly appreciated,

Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator James Huff


    Volunteer Moderator 🚀

    It sounds like your account may have lost full admin privileges for some reason.

    Access your database via phpMyAdmin (most hosting providers offer this in their control panel), go to the wp_users table and find the row for your user_login . Note the ID of this row. Now, go to the wp_usermeta table and find the wp_capabilities row for your user_id . Set the value of this row to a:1:{s:13:"administrator";b:1;}


    I had this value: a:1:{s:13:"administrator";s:1:"1";}

    I changed it but the error is still there.

    any other idea please?

    By the way… i’ve logged in with another user that I had, just to see if it was a “User” problem… but with both users I get the same error, so I think is a programming or a setting problem

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘"You don't have enough permissions" error in only some menu items’ is closed to new replies.