WordPress.org

Support

Support » Alpha/Beta » You do not have sufficient permissions to access this page.

You do not have sufficient permissions to access this page.

  • When trying to access my admin, I get this error: “You do not have sufficient permissions to access this page.” http://www.kurtdamron.com The page looks fine, but I don’t have an option to post. I do however see “logout” even though it says I don’t have sufficient permissions to post and what not. Thanks in advance for any help you can offer.

Viewing 15 replies - 1 through 15 (of 30 total)
  • Are you sure you are logged in as admin and not as some lower level user?

    yep…that’s the only user name and password I have ever used…admin and my password. It’s really weird.

    yep…that’s the only user name and password I have ever used…admin and my password. It’s really weird.

    Hey, look at this, the same error I am getting:
    http://wordpress.org/support/topic/52522

    Having similar problem. I can log into admin, but I cannot post or edit posts.

    So far what I have done and with no results.
    I should state that this is an upgrade from 1.5.2. After the upgrade and I started recieving the error.

    I have rebuilt the .htacces (using the permalinks option under admin), I went through and double checked the the settings to make sure I still had the appropriate rights (administrator), I have created a new user and given that user admin rights and still no luck.

    I cannot create or edit posts. I cannot edit pages but I can create new ones. I cannot edit comments but comments can be made. I can edit and create links and categories. Create and edit users works with no problems.

    I have upgraded to 2.0 non beta yadda yadda yadda. I still do not have sufficent priveldges to post edit etc.

    Should I look at the db tables and make any adjustements to the uesrs_meta and users tables? I dont know what to set them to and double check against.

    Aaron

    I just re-ran upgrade.php and that seemed to fix it.

    I’m trying to build this on a test site. I first built my 1.5 blog and database, made sure it worked and then followed the instructions as specified to upgrade it.

    The upgrade went well, tables built and populated as I’d expect but when I log in as admin, I get the same error about not having permissions. I can get to the dashboard but I only get a few options and none of the admin options. The other interesting thing is the user welcome in the upper right corner. I get “Hello, .” I’m guessing the . should be admin. I also signed out and requested my password. It sent me the email, I clicked the link and then it sent me a new password. I tried the password and it did not work so I tried my old password and that let me in.

    I wiped out the database and ran install.php and now I get a loop, it states I need to run install. I run install it tells me I’ve already installed it.

    Thoughts?

    http://wordpress2.rons-sandbox.com

    Ron Hagerman

    phoenix522:
    Well since you wiped out your database why not start from the very beginning, including deleting all wordpress files (except for wp-config.php and any themes or plugins). Make sure you delete wp-content/cache.

    See:
    Installing WordPress

    Yep, I did that as well. No luck. I’ve tried it both ways. With the clean install, I get the endless loop and with the upgrade, I get the other problem.

    I’m running on a Windows 2003 server (shared hosting through MDS-Host) and 1.5 works well.

    After your post, I thought about it and did the upgrade which gave me the same error. I deleted wp-content/cache and now it works. It gave me an error stating my database was out of date and a link to upgrade. I ran the upgrade again and now all is well.

    This is now fixed!

    Thanks

    Ron

    I ran into both the 403 Forbidden error and the one included as the topic of this post. The 403 error I fixed by adding the line:

    DirectoryIndex index.html index.php

    Witihin the VirtualHost defined in my local.conf (a.k.a httpd.conf) file for Apache. W/o it Apache didn’t know to open up /wp-admin/index.php when wp-login.php redirected to /wp-admin/ upon logging in as the administrator.

    I fixed the “You do not have sufficient permissions to access this page.” error by changing the following line in my PHP.ini:

    magic_quotes_runtime = Off

    It was set to “On”, and was therefore escaping quotes from data taken from the database. The code for wordpress can probably be changed so this directive can remain “On” if you’d rather be more secure, I suppose. That’s just a hunch.

    Anyways, these two small changes worked for me. Just thought I’d share.

    hi,
    I’ve the same problem .. i’ve re-uploaded all the files excepted wp-congig, themes and plugins and re-run upgrade.php, deleted /wp-content/cache, but it doesn’t work, i’ve always “You don’t …”

    I had the same problem, I deleted the cache-folder and that solved my problem.

    Running Wp2 om Win2k3 srv.

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘You do not have sufficient permissions to access this page.’ is closed to new replies.
Skip to toolbar