Support » How-To and Troubleshooting » [Resolved] You do not have sufficient permissions to access this page. after wp 2.8.1

[Resolved] You do not have sufficient permissions to access this page. after wp 2.8.1

  • Today i have upgraded my WP version to 2.8.1 and adsense delux plugin page showing the following error

    You do not have sufficient permissions to access this page.

    Can some one help me to fix this

Viewing 15 replies - 1 through 15 (of 21 total)
  • guys can some one help me to fix this problem

    i am using this adsense plugin v 0.8


    If it’s like this problem, http://wordpress.org/support/topic/288584 then the plugin developer may need to fix their menu security.

    thank u so much for your reply.Currently plugin developer stopped this plugin development.I really need help from someone to fix this problem

    Just use some other plugin like Easy Adsenser, there any many available.

    This also happened to me after the upgrade to 2.8.1. With the plugin Email-Users.

    This also happened to me after the upgrade to 2.8.1. With the plugin Email-Users.

    Exactly the same here with 2.8.1 and Email-Users
    So, we must to wait for a plugin update… Right?


    Require all plugin page requests (?page=) to be for registered plugins pages. Provides CYA for plugins that don’t do enough cap checking. action requests not bound to a plugin page still go through.

    Any word on an update for Email-Users Plugin? I have checked over the changes but I am not sure what I need to do to get this plugin functioning. It is a very popular plugin, which unfortunately is no longer developed.

    Okay so I am not sure whats going on here but I am currently working on getting this fixed. It may take me a little while because I am unfamiliar with programming a plugin for wordpress. I currently have the plugin working but the way i did it is a bit rediculous. I found two pages that were working from the plugin:


    I then copied everything from:

    and copied everything from:

    In order to get email-users/email_users_group_mail_form.php to open up email-users/email_users_send_group_mail.php when i submit the query I edited the line in email-users/email_users_group_mail_form.php

    <form name=”SendEmail” action=”post-new.php?page=email-users/email_users_send_group_mail.php” method=”post”>

    and changed it to:

    <form name=”SendEmail” action=”post-new.php?page=email-users/email_users_overview.php” method=”post”>

    So now whenever I want to write an email to all my users i have to go to:

    Yes i know this is completely screwed up, but I use this plugin on a daily basis and this is going to have to work for now. I am going to try to edit the plugin and see if I can figure out how to make it work properly.

    Hey all, here’s my fix for adsense deluxe, WordPress 2.8. I don’t know much about advanced plugins, but I know how to fix things when they break: DUCT TAPE. If I had an actual non-zombie blog, well, I’d blog this.

    In the file /plugins/adsense-deluxe.php, Around line 1013, comment out the following:

    function add_adsense_deluxe_menu()
    if (function_exists(‘add_options_page’)) {
    add_options_page(‘AdSense-Deluxe Configuration’, ‘AdSenseDeluxe’, 8, __FILE__); //’AdsenseDeluxeOptionsPanel’); // wp 1.5.1 version

    and add:

    function add_adsense_deluxe_menu(){
    add_options_page(__(‘AdSense-Deluxe Configuration’, ‘adsense-deluxe’), __(‘AdSense-Deluxe’, ‘adsense-deluxe’), 8, ‘adsense-deluxe’, ‘AdsenseDeluxeAdminPage’);

    function AdsenseDeluxeAdminPage(){
    require (WP_PLUGIN_DIR . ‘/adsense-deluxe.php’);

    then at about line 1095, replace

    add_action(‘admin_head’, ‘add_adsense_deluxe_menu’);


    add_action(‘admin_menu’, ‘add_adsense_deluxe_menu’);

    And, awesome, it works!

    Found the solution, do the followings:

    0. deactivate adsense-delux
    1. download adsense-delux from servier
    2. open up adsense-delux.php and change admin_head to admin_menu
    3. upload back to server.
    4. check – you should have permission now.



    Good luck 😉

    forge22, your code change works thanks.

    But, the quick tag button does not appear in the editor.

    Any ideas?

    I have a very similar problem with the WP-PHPList plugin. Any idea where to fix it?

    Author: David Young
    Author URI: http://www.funkypenguin.co.za
    Description: Administrative options for WP-PHPList
    This file is the configuration options for the WP-PHPList plugin
    It should be placed within your wp-content/plugins/wp-phplist directory
    load_plugin_textdomain('wpcf'); // NLS
    $location = get_option('siteurl') . '/wp-admin/admin.php?page=wp-phplist/wp-phplist-options.php'; // Form Action URI
    /*Lets add some default options if they don't exist*/
    if(get_option('wp_phplist_slug') == '') {
    	add_option('wp_phplist_slug', 'wp-phplist.php');
    if(get_option('wp_phplist_spage') == '') {
    	add_option('wp_phplist_spage', '1');
    if(get_option('wp_phplist_title') == '') {
    	add_option('wp_phplist_title', 'Our Newsletters');
    if(get_option('wp_phplist_phplist_path') == '') {
    	add_option('wp_phplist_phplist_path', 'lists');
    /*check form submission and update options*/
    if ('process' == $_POST['stage'])
    update_option('wp_phplist_slug', $_POST['wp_phplist_slug']);
    update_option('wp_phplist_spage', $_POST['wp_phplist_spage']);
    update_option('wp_phplist_title', $_POST['wp_phplist_title']);
    update_option('wp_phplist_phplist_path', $_POST['wp_phplist_phplist_path']);
    /*Get options for form fields*/
    $wp_phplist_slug = get_option('wp_phplist_slug');
    $wp_phplist_spage = get_option('wp_phplist_spage');
    $wp_phplist_title = get_option('wp_phplist_title');
    $wp_phplist_phplist_path = get_option('wp_phplist_phplist_path');
    <div class="wrap">
      <h2><?php _e('WP-PHPList Options', 'wpcf') ?></h2>
      <form name="form1" method="post" action="<?php echo $location ?>&updated=true">
    	<input type="hidden" name="stage" value="process" />
        <table width="100%" cellspacing="2" cellpadding="5" class="form-table">
          <tr valign="top">
            <th scope="row"><?php _e('PHPList public pages slug:') ?></th>
            <td><input id="inputid" name="wp_phplist_slug" type="text" id="wp_phplist_slug" value="<?php echo $wp_phplist_slug; ?>" size="50" />
            <br />
    <?php _e('The "slug" to the main PHPList page, relative to wordpress. Defaults to the name of the script. You may want to create a custom rewrite rule.', 'wpcf') ?></td>
          <tr valign="top">
            <th scope="row"><?php _e('PHPList default subscribe page:') ?></th>
            <td><input id="inputid" name="wp_phplist_spage" type="text" id="wp_phplist_spage" value="<?php echo $wp_phplist_spage; ?>" size="50" />
            <br />
    <?php _e('Enter the number of the default subscribe page to use, or leave blank to let PHPList generate an index', 'wpcf') ?></td>
          <tr valign="top">
            <th scope="row"><?php _e('PHPList embedded page title:') ?></th>
            <td><input id="inputid" name="wp_phplist_title" type="text" id="wp_phplist_title" value="<?php echo $wp_phplist_title; ?>" size="50" />
            <br />
    <?php _e('Enter the title to be displayed on the page with the embedded PHPList results', 'wpcf') ?></td>
          <tr valign="top">
            <th scope="row"><?php _e('PHPList relative path:') ?></th>
            <td><input id="inputid" name="wp_phplist_phplist_path" type="text" id="wp_phplist_phplist_path" value="<?php echo $wp_phplist_phplist_path; ?>" size="50" />
            <br />
    <?php _e('Enter the path of your PHPList installation, relative to WordPress', 'wpcf') ?></td>
        <p class="submit">
          <input type="submit" name="Submit" value="<?php _e('Update Options', 'wpcf') ?> &raquo;" />

    I have the same problem with ASP.

    This is a bug caused by WordPress changing stuff, and it ought to be fixed, so we don’t have to trash expensive plugins.


    has instructions

    It seems to have worked just fine for me – hand editing v0.8 of adsense-deluxe.php and wordpress 2.8.2 will now let me back in to the settings page.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Resolved] You do not have sufficient permissions to access this page. after wp 2.8.1’ is closed to new replies.