"You do not have sufficient permissions to access this page" after url migration (4 posts)

  1. Aommys
    Posted 3 years ago #

    So i had a fine working installation of wordpress in a directory /var/www/wportal with a site url http://sitename/wportal. And i needed to migrate it all from /wportal to /portal.

    So i took the following steps:
    1) used Search and Replace plugin to change every wportal string in the database to portal.
    2) changed the site and home url in the wp-config.php (here's the final http://pastebin.com/s9TpPQC8 )
    3) did "mv wportal" portal/"
    4) restarted apache
    So the site works fine but when i login in the wp-admin after a succesfull login it says "You do not have sufficient permissions to access this page".

    I did "mv wp-content/plugins wp-content/plugins_old" to check if a plugin was causing the problem but nothing changed.

    I read and tried everything in http://codex.wordpress.org/Login_Trouble
    but still nothing changed.
    I did not change the database table prefix or something like that neither did i change any file permissions so i just don't understand why it doesn't work. :\

    Here's my phpinfo() : http://pastehtml.com/view/b9t4yamn6.html

    I could really use some help.

  2. Tim S
    Posted 3 years ago #

    Hi Aommys,

    I would check to see what file permissions you have set up on the WordPress pages. If that doesn't have you recently upgraded. I see a lot of issues about upgrading and privileges.

    Here's a link to an article about it. See if this helps:


  3. Aommys
    Posted 3 years ago #

    Ok the force-upgrade.php worked and i now can view the dashboard and my profile on the left side on the screen but all the other controls are gone! I can't see pages, posts, appearance etc. Nothing. :\

    Weird. Here's my usermeta for the webmaster user.

  4. Aommys
    Posted 3 years ago #

    Ok so i tried this

    FIXED!!!! OK gang – if you run the script and can then LOGIN but only get the Dashboard and Profile, you must do 2 things 1) In you wp_usermeta table make sure your meta_key entries are correct (e.g. wp_capabilities and wp_userlevel on a default configuration. 2) delete the extra wp_capabilities entries the script has added to the end of your table. by default if will add a:1:{s:13:”subscriber”;b:1;} to your wp_capabilities – which makes your admin account a subscriber only.

    And now i have way more options in my panel but i still don't have the widgets option, the add new plugin option and i can't administrate any user etc.
    Any ideas?
    This is my usermeta table
    Though I don't think the problem is in the wportal_usermetadata anymore. :\

Topic Closed

This topic has been closed to new replies.

About this Topic