Support » Networking WordPress » You do not have sufficient permissions to access this page.

  • Resolved madivad


    I just upgraded from 3.0 (or maybe 3.0.1???) to 3.2.1 and now I am getting the error: “You do not have sufficient permissions to access this page.”

    I almost posted this in the multisite section because I run multisites and I think it MAY be to do with that, but I’m not 100% sure, hence, I’ve posted it here.

    I believe it’s a permission based error based on the database prefix that multisite plays with.

    If noone in single site land is having an issue, maybe this could be reposted in the multisite area. Thanks

Viewing 11 replies - 1 through 11 (of 11 total)
  • Moderator Ipstenu (Mika Epstein)


    Lead Plugin Wrangler

    On which page are you receiving the error? ALL admin pages or …?

    admin, whn trying to log in, luckily, the site otherwise (to guests) looks normal.

    It is a multi site, so when I log in, it goes thru the main doman and then hands back – if that helps

    But what’s most confusing a bout this error, it’s not for a secure page, it’s for the login page. I’m starting to think it must have been an upgrade error (automated), something to do with the multi-site. Because when I click on new post or dashboard from the guest side of my site, it portals off to the head site but then locks out at the login screen. I can not even see that….

    Why would the login page have security attached to it?

    Moderator Ipstenu (Mika Epstein)


    Lead Plugin Wrangler

    Moved this over to MultiSite.

    If you see the admin tool bar, you are (to some degree) logged in. try logging out and deleting all your site cookies in your browser.

    I don’t see any admin bar, the new post and dashboard links I refer to I always have visible so that I have an easy way to login.

    I did just try something different, I used a browser I don’t normally use (Safari on osx) and I actually got to the login page. A first. I deliberately logged in incorrectly, got the shaken login box. All good. Entered the correct password and was forwarded to a page with the dreaded: You do not have sufficient permissions to access this page.

    I just used:
    [myUrRL]/wp-login.php?action=logout and was allowed to log out of the site.

    I could then go to the login page and was allowed to login, but tonce there, I have no permissions to do anything. going to my datatbase I appear to have the right permissions (compared to others I’ve found on the web), but maybe someone can see something I can’t:

    my user id is obviously 1, in the usermetadata:
    wp_capabilities –> a:1:{s:13:”administrator”;s:1:”1″;}

    If someone could point me to the right part of the db to look at, it would be appreciated

    this is present in sitemeta, I have removed my login name:

    site_admins a:2:{i:0;N;i:1;s:4:”MyName”;}

    in the same area:
    wpmu_upgrade_site 15477

    and in wp_blog_versions:
    6 18226 2010-07-31 10:30:49
    2 15477 2010-07-31 10:53:40
    5 15477 2010-07-31 12:01:24
    4 15477 2010-07-31 12:01:27
    3 18226 2010-07-31 12:01:29
    1 18226 2010-07-31 12:01:32

    Some updated, and it would appear that some did not… #6 is the only important one

    wp_3_capabilities a:1:{s:13:”administrator”;s:1:”1″;}
    exists, as it does for the other blogs as well. wp_2, wp_4, wp_5 and wp_6

    all user levels for me are set to 10,

    and my user-settings are:

    Ok, it took some digging and I found MY solution to this problem. Short version: apparently I forgot to deactivate all my plugins before I started. A faulty plugin was to blame.

    I have detailed how I fixed it here:


    (Too add to this thread for anyone else with the same error message)

    I had the same problem, but not the same reason. I ‘had’ disabled my plugins before turning the site into multisite.

    The issue was still plugins though. I got the “…sufficient permissions…” message after I activated my plugins again.

    I did the same as madivad to fix it though:

    (1) Accessed the site files (you can do that via ftp client or file manager in cPanel).
    (2) Renamed my plugins folder to /wp-content/plugins-2
    (3) Created a new empty folder called /wp-content/plugins
    (4) Went to wp-admin and i was allowed to log in again.
    (5) From the site files back end, I moved the index file from /plugins-2 to /plugins
    (6) From the site files back end, I moved my plugins 1 by 1 from /plugins-2 to /plugins and refreshed my plugins installed page in the site admin after each one, till I found the problem plugin (page wouldn’t refresh properly).
    (7) From the site files back end, I moved the incompatible plugin back to /plugins-2 folder
    (8) From the site files back end, I continued with the rest of the plugins 1 by 1 till I was happy what worked and what didn’t.

    Thanks to madivad, and I hope this helps someone,


    In case anyone is trying to clone an installation and gets this same error attempring to login, here’s a quick and simple fix that put things right.

    Go to the usermeta table in the new database. Change all meta key references to the new prefix. For example:
    old meta_key: wp_capabilities —> newprefix_capabilities,
    old meta_key: wp_user_level —> newprefix_user_level



    I got the same problem just after installing the multisite version on 3.3.1.
    The network activation of the plugins created havoc.
    I tried everything which has been explained, but it did not work.
    I finally found out that it was the plugin W3-total-cache which was at the root of the problem.
    I deleted it’s folder + advanced-cache.php, db.php,objet-cache.php and w3-total-cache-config.php to, finally be able to login again.
    For a non-technician, this has been pretty scary, and must be what is called “learn the hard way”.
    Thanks to Dave to have oriented me in the right direction anyway.

    THEN: I reactivated my plugins, one by one in Network Activate, until I came again to the message “ not have the permissions…”
    Whatever plugin I tried after this, I got blocked, when I did not encounter any problem with the first 24 of them.
    Does anybody have an idea about this ??

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘You do not have sufficient permissions to access this page.’ is closed to new replies.